Unable to get forum back online after adding plugins


(Jake Whitaker) #1

I’m using Digital Ocean hosting, as recommended. I took some time today to attempt to install some plugins, and made a mess (because, well, that’s what happens when you require people in a GUI-based market to run a shell for plugin installation).

At first there were some typos in the git clone commands added to the app.yml file when I ran the rebuild, and eventually I fixed those only to find I’d deleted a / in the SSH call. Fixed that, ran the rebuild again, and still nothing. I’ve confirmed that the container files at least still exist, and I cancelled mid-bootstrap during one of the attempts (which I fear might’ve broken everything, since I didn’t realize that ctrl+z would DO THAT). Tried running the bootstrap on its own and got this error.

Image.

I’d grab the log if I knew how to copy/paste the damn thing. I attempted to install Tagger, the Checklist, and shared editing privileges, and apparently attempted to copy Tagger which you aren’t supposed to do either. As an otherwise extremely satisfied user, I’m more than a bit miffed that I’ve spent four hours breaking my forum for lack of something as standard as ACP-based plugin installs.

Does it look like I’m screwed? My forum’s giving an ERROR 102.


(Jeff Atwood) #2

Plugins are for very advanced users only at this point.

I recommend you overwrite your app.yml with the default version and edit the fields described in the install doc. Then rebuild the container.


(Jake Whitaker) #3

Gave that a shot, but the forum’s still an unavailable webpage.

Checked the logs, and it’s basically all this same error.

Image.


#4

Had the same error on a test server. SSH into the server and create that dir and it should work.

Background: Tried to install discourse on a ARM server with the install-linux.md… Discourse worked in the end though.


(Richard - DiscourseHosting.com) #5

Ctrl-z doesn’t cancel. It just stops the process. That’s why it says it’s already running when you try to start it again.
Type fg to resume it.


(Jake Whitaker) #6

Managed to get everything back up and running. Predictably, it was something completely unrelated to any of this. I hadn’t upgraded all of the background programs so rebuilding discourse went awry throughout the entire process. D’oh.