# No se puede instalar Discourse: módulo aufs no encontrado

**URL:** https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212
**Category:** Self-hosting
**Created:** [26 Abril, 2016 02:52 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212 "2016-04-26T02:52:47Z")
**Posts on this page:** 14
**Page:** 1

<div class="post-metadata">

### Author: ![prateekvarma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/prateekvarma/32/57928_2.png) [@prateekvarma](https://meta.discourse.org/u/prateekvarma)
#### Post date: [26 Abril, 2016 02:52 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/1 "2016-04-26T02:52:47Z")

</div>

When i do `wget -qO- https://get.docker.com/ | sh`

The very next line says `modprobe: FATAL: Module aufs not found.`

But the installation continues, but after doing “./launcher bootstrap app” and “./launcher start app” i get fatal errors.

I am following the [OFFICIAL install](https://meta.discourse.org/t/142537?silent=true) guide steps on a standard ubuntu 14.04 LTS. Whatsup?

(PS - my email SMTP credentials are correct)

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [26 Abril, 2016 03:09 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/2 "2016-04-26T03:09:38Z")

</div>

Docker is not installing properly. Until docker is installed properly nothing will work.

---

<div class="post-metadata">

### Author: ![prateekvarma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/prateekvarma/32/57928_2.png) [@prateekvarma](https://meta.discourse.org/u/prateekvarma)
#### Post date: [26 Abril, 2016 03:15 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/3 "2016-04-26T03:15:39Z")

</div>

…how can i install it properly?

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [26 Abril, 2016 03:18 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/4 "2016-04-26T03:18:53Z")

</div>

> [@Docker install: Module aufs not found](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494):
>
> Hey, Immediately after running the docker install command wget -qO- https://get.docker.io/ | sh I get the following error. “modprobe: FATAL: Module aufs not found.” I’m on digital ocean, 2GB Ram 40GB SSD. I have followed the guide exactly. redis, postgres has been installed and working properly.

PS: What’s your vps provider?

---

<div class="post-metadata">

### Author: ![prateekvarma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/prateekvarma/32/57928_2.png) [@prateekvarma](https://meta.discourse.org/u/prateekvarma)
#### Post date: [26 Abril, 2016 03:21 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/5 "2016-04-26T03:21:22Z")

</div>

this one is on OVH.  
I don’t understand, if it is a standard Ubuntu 14.04 LTS, what could be different?

---

<div class="post-metadata">

### Author: ![prateekvarma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/prateekvarma/32/57928_2.png) [@prateekvarma](https://meta.discourse.org/u/prateekvarma)
#### Post date: [26 Abril, 2016 03:52 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/6 "2016-04-26T03:52:30Z")

</div>

OK…

This is the 4th time i tried to install, after trying the “fix” in the thread provided by @Falco which is

```
sudo apt-get install lxc wget bsdtar curl
sudo apt-get install linux-image-extra-$(uname -r)
sudo modprobe aufs

```

I still get the error:

```
FAILED
--------------------
RuntimeError: /usr/local/bin/ruby -e 'if ENV["DISCOURSE_HOSTNAME"] == "discourse.example.com"; puts "Aborting! Domain is not configured!"; exit 1; end' failed with return #<Process::Status: pid 219 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params "/usr/local/bin/ruby -e 'if ENV[\"DISCOURSE_HOSTNAME\"] == \"discourse.example.com\"; puts \"Aborting! Domain is not configured!\"; exit 1; end'"
d0ee9b65b9f5191547ee326f11251162835f0dc68446622349ccae6cf07bb214
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [26 Abril, 2016 03:54 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/7 "2016-04-26T03:54:58Z")

</div>

It says the domain is not configured in the error you posted. Make sure `docker info` shows aufs as the filesystem and `docker version` is correct.

---

<div class="post-metadata">

### Author: ![prateekvarma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/prateekvarma/32/57928_2.png) [@prateekvarma](https://meta.discourse.org/u/prateekvarma)
#### Post date: [26 Abril, 2016 03:58 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/8 "2016-04-26T03:58:37Z")

</div>

### docker info

```
Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 1
Server Version: 1.11.0
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 6
 Dirperm1 Supported: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins: 
 Volume: local
 Network: null host bridge
Kernel Version: 3.13.0-55-generic
Operating System: Ubuntu 14.04.4 LTS
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 1.908 GiB
Name: sitename.com
ID: 46DY:WHRC:PSQ2:Q3PG:KR2N:QEN2:2YZ2:SOOX:4HRQ:CLFH:7ZHY:5MYD
Docker Root Dir: /var/lib/docker
Debug mode (client): false
Debug mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No swap limit support

```

### docker version

```
 Client:
 Version: 1.11.0
 API version: 1.23
 Go version: go1.5.4
 Git commit: 4dc5990
 Built: Wed Apr 13 18:34:23 2016
 OS/Arch: linux/amd64

Server:
 Version: 1.11.0
 API version: 1.23
 Go version: go1.5.4
 Git commit: 4dc5990
 Built: Wed Apr 13 18:34:23 2016
 OS/Arch: linux/amd64

```

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [26 Abril, 2016 04:10 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/9 "2016-04-26T04:10:52Z")

</div>

That looks fine now. Read the error. Your domain is not configured in app.yml

---

<div class="post-metadata">

### Author: ![prateekvarma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/prateekvarma/32/57928_2.png) [@prateekvarma](https://meta.discourse.org/u/prateekvarma)
#### Post date: [26 Abril, 2016 04:13 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/10 "2016-04-26T04:13:35Z")

</div>

When i do a `nano containers/app.yml` , it opens a new file now? Wut? What is this now? — this was my stupidity.

Here is my domain in my app.yml

```
DISCOURSE_HOSTNAME: 'discourse.example.com'

```

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [26 Abril, 2016 04:22 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/11 "2016-04-26T04:22:59Z")

</div>

You are expected to change [example.com](http://example.com) to the domain you bought.

---

<div class="post-metadata">

### Author: ![prateekvarma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/prateekvarma/32/57928_2.png) [@prateekvarma](https://meta.discourse.org/u/prateekvarma)
#### Post date: [26 Abril, 2016 04:39 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/12 "2016-04-26T04:39:42Z")

</div>

The instruction —

> Set DISCOURSE\_HOSTNAME to [discourse.example.com](http://discourse.example.com), this means you want your Discourse available at [http://discourse.example.com/](http://discourse.example.com/). You’ll need to update the DNS A record for this domain with the IP address of your server.

I really think that you should specify it more clearly there.

And i changed [discourse.example.com](http://discourse.example.com) to [mydomain.com](http://mydomain.com), not just [example.com](http://example.com) …

It is working fine now…  
Thanks.

---

<div class="post-metadata">

### Author: ![steko](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@steko](https://meta.discourse.org/u/steko)
#### Post date: [26 Abril, 2016 08:01 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/13 "2016-04-26T08:01:16Z")

</div>

For the record, you automatically get a domain like [vps12345678.ovh.net](http://vps12345678.ovh.net) with all OVH VPSs, it turned out to be useful for testing.

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [8 Junio, 2024 12:45 UTC](https://meta.discourse.org/t/unable-to-install-discourse-module-aufs-not-found/43212/14 "2024-06-08T12:45:47Z")

</div>

Este tema se cerró automáticamente después de 2965 días. Ya no se permiten nuevas respuestas.
