Unable to Install the Plugin for Advertise and other


(Askjoyb) #1

Hi Team,

I have done changes as per the instructions on the website but still have issue

  1. Done the File Edit
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          – mkdir -p plugins
          - git clone https://github.com/discourse/docker_manager.git
          – git clone https://github.com/discourse/discourse-spoiler-alert.git
          - git clone https://github.com/discourse/discourse-chat-integration.git
          - git clone https://github.com/discourse/discourse-adplugin.git

Next when i run - git pull it says, git pull - Shows - Already up-to-date. (not pulling any information)

Then when i rebuild it fails

./launcher rebuild app
Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 10 app
app
cd /pups && git pull && /pups/bin/pups --stdin
Already up-to-date.
I, [2018-09-23T06:07:01.258185 #14]  INFO -- : Loading --stdin
/pups/lib/pups/cli.rb:15:in `split': invalid byte sequence in US-ASCII (ArgumentError)
        from /pups/lib/pups/cli.rb:15:in `run'
        from /pups/bin/pups:8:in `<main>'
7bfaa7cccfa02ecadea2fc89e6ee2d54c5f813f8070f57d1babe4e40c688dee8
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

Can anyone help ?


(Glenn Sims) #2

It looks like the dashes for the mkdir and git clone for Discourse Spoiler Alert aren’t YAML-supported. This may also be with Discourse’s formatting, but from the looks of an ASCII issue it might be the text.

Make sure that each command is only using one dash (-) and not two dashes (–).

This is what the dashes look like on my screen:

image


(Askjoyb) #3

thanks for the reply - dash are same after copy it may showing like this - let me verify it again


(Askjoyb) #4

updated same result

hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
         - mkdir -p plugins
         - git clone https://github.com/discourse/docker_manager.git
         - git clone https://github.com/discourse/discourse-spoiler-alert.git
         - git clone https://github.com/discourse/discourse-chat-integration.git
         - git clone https://github.com/discourse/discourse-adplugin.git

(Glenn Sims) #5

Try removing plugins one at a time and see which one might cause the error. Could be a programming issue.
(Word of advice: process of elimination will always help solve most errors!)


(Askjoyb) #7

is there any support Team can help - not working still have same issue


(Jeff Atwood) #8

I suggest contacting https://www.literatecomputing.com if you need paid assistance.


(Askjoyb) #9

Ok - but its bit expensive


(Jeff Atwood) #10

You could also post a #marketplace topic with your budget and what you wish to be done.


(Askjoyb) #11

yes still trying :slight_smile: but i have followed the exact method but still dont what is the issue