Unable to make SSL to work on my Discourse installation

unsupported-install

(Indicado 👌) #1

Hello,

Since Bitnami isn’t very active on their forums and i need some help, i’ll be posting this here.

i installed Discourse a couple days ago and i’m installing a SSL certificate. I’m using StartSSL certificate, and i already verified my domain (https://wonh.cf) but it still shows me that the domain is not veryfing and idk why its still using the dummy certificate, i checked all the paths and they were correct, so please notice me if i need to restart something (restarted apache a hundred times) and still not working…

what i should do?


(Indicado 👌) #2

also saying that im using the Bitnami Discourse stack, i already know that i should post this on their forums but already did it and they are not probably going to help me.


(Jeff Atwood) #3

If you want support here you’ll need to follow our official install guide.


(Indicado 👌) #4

Ok, how to port ALL the configuration that i had on Bitnami, such as groups, custom CSS’, categories and all? If im able to do that without doing it manually tomorrow i will install it from scratch.


(Joshua Rosenfeld) #5

That should all be included in a backup, unless I am mistaken. Should be as simple as taking a backup, installing via the official guide, enabling restore, and then restoring the backup.


(Régis Hanol) #6

Do a backup on Bitnami install and restore it on your newly & supported docker install :wink:


(Indicado 👌) #7

Thanks. Replying again this thread when done.


(Kane York) #8

You should also be aware of this:


(Indicado 👌) #9

I’m already aware of it, but i need an SSL certificate and i trust them. If not i’ll try LetsEncrypt


(Indicado 👌) #10

Bad news, trying to installing Docker, it doesn’t let me start the Docker Engine, and sudo docker daemon -s overlay says this:

sudo docker daemon -s overlay INFO[0000] libcontainerd: new containerd process, pid: 11303 WARN[0000] containerd: low RLIMIT_NOFILE changing to max current=1024 max=65536 FATA[0001] Your Linux kernel version 2.6.32-openvz-042stab116.2-amd64 is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer.

Why is my kernel unsopported? I’m not able to install again Ubuntu as im using a VPS. What i should do now?

Im using Ubuntu 16.04 Xenial.


(Rafael dos Santos Silva) #11

OpenVZ virtualization doesn’t suport Docker. You need a KVM VPS server.

Digital Ocean works.


(Indicado 👌) #12

Can’t by now, isn’t there any Docker modification to allow it?


(Rafael dos Santos Silva) #13

No, there isn’t. And we only support docker installs with Aufs filesystem.