Unable to pinch zoom on ASUS Memopad 7 running Android


(Rob Nicholson) #1

I’m unable to pinch zoom on my 7" tablet and I find the font just a little too small for my weary eyes. I do wear specs on the PC but I’m normally fine on here and my phone. Is there a way to either enable pinch zoom or maybe bump up the fonts by a few points?


(Jeff Atwood) #2

Are you in mobile layout? You should be, if you’re accessing this site or any very recent version of Discourse as we now heavily favor mobile layouts on Android devices. Visit the hamburger menu at upper right and check.

Perhaps if you could share a screenshot.


(Rob Nicholson) #3

Yes am in mobile layout - for example no preview pane as I type this response. Chrome on Android KitKat.


(Jeff Atwood) #4

That does sound like the mobile layout, can you please share a screenshot?


(Rafael dos Santos Silva) #5

Discourse mobile disable zoom.

You can go into chrome settings > accessibility > font scaling to make text bigger.


(Rob Nicholson) #6

Also, it’s not possible to get the cursor into the text box without minimising the keyboard and then clicking. Mainly because one can’t scroll the display.


(Rob Nicholson) #7

Thanks but won’t that be a global change? It’s fine for everything else - as one can pinch zoom.


(Tom Newsom) #8

I know this is unhelpful for the issue in question, but that screenshot contains so many design mistakes. Please excuse a quick rant list.

  1. 16:9 (even 16:10 in this example) is a bad aspect ratio for a tablet when you’re typing in landscape
  2. The Back, Home, Switcher bar is a terrible waste of precious vertical screen space
  3. The tab and address bar only make things worse
  4. The status bar is the icing on the cake.
  5. Result: 258px actual visible space. 178px on a 16:9 screen.

Makes me sad :frowning:


(Rob Nicholson) #9

To be fair, this is as much an Android problem as it is Discourse - it’s a common problem in landscape mode with a budget tablet. My tablet spends most of it’s time with a Bluetooth keyboard but not always - I’ve only got the touch screen keyboard on in this example because I’d just had it out of it’s case. It’s using the Swype keyboard which I love - although Google Keyboard does much the same. That’s the smallest I can get it to go - although it could cope with going even smaller. But yes, there is too much clutter around.


(Rob Nicholson) #10

Another aside: another perennial problem with Android tablets paired with keyboards is that there is no spell checker. Some applications such as Inbox for Gmail do add on-screen spell checking via the red squiggly line system but on that system above, I don’t get spell checking with Discourse. The reason I assume that apps don’t have built-in spell checkers is that they assume the on-screen keyboard will have predictive text.


(Tom Newsom) #11

Oh yes, this was entirely my point. No offence intended to Discourse!


(Jeff Atwood) #12

About all you can do here is press the hamburger button to hide the editor toolbar. Beyond that you are at the mercy of your OS and the way it squanders all the screen space in landscape on that device.

I am pretty sure you can turn suggestions on the keyboard off which would save some space just above the keyboard as well.


(Sam Saffron) #13

I think I can do something here, when it moved to full screen I can set a min-height on the composer textarea, the “safari+android” hack should be in place for all touch devices really.


(Rob Nicholson) #14

Yes you can but then you don’t get any spell checking when composing a reply. Although I’ll have to double check this as by default, Chrome on my Android, doesn’t spell check in text boxes.


(Kane York) #15

Please don’t force touchscreen laptops with plenty of screen space into a full screen composer, thanks…


(Rob Nicholson) #16

True - it’s fine on my Windows 10 touchscreen laptop with 15" screen.
Should check screen resolution I guess. Cheers,Rob


(Rob Nicholson) #17

Has there been any movement on this? I still find the font too small when composing topics on my 7" ASUS Android tablet. I appreciate pinch zoom has probably been disabled for very good reasons but if that’s the case, please give me a option to configure the font sizes personally.