# Incunable reinstalar Discourse

**URL:** https://meta.discourse.org/t/unable-to-reinstall-discourse/310691
**Category:** Self-hosting
**Created:** [5 Junho , 2024 17:27 UTC](https://meta.discourse.org/t/unable-to-reinstall-discourse/310691 "2024-06-05T17:27:53Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![peyrusse](https://avatars.discourse-cdn.com/v4/letter/p/8dc957/32.png) [@peyrusse](https://meta.discourse.org/u/peyrusse)
#### Post date: [5 Junho , 2024 17:27 UTC](https://meta.discourse.org/t/unable-to-reinstall-discourse/310691/1 "2024-06-05T17:27:53Z")

</div>

Olá,

Tentei reinstalar o Discourse do zero. E a instalação falha, tenho um erro para verificar o primeiro certificado que nunca tive antes. E então a instalação falha…

Alguma ideia do que pode ser o problema?

```plaintext
> warning Resolution field "unset-value@2.0.1" is incompatible with requested version "unset-value@^1.0.0"
**error Error: unable to verify the first certificate**
    at TLSSocket.onConnectSecure (node:_tls_wrap:1659:34)
    at TLSSocket.emit (node:events:517:28)
    at TLSSocket._finishInit (node:_tls_wrap:1070:8)
    at ssl.onhandshakedone (node:_tls_wrap:856:12)
I, [2024-06-05T17:24:31.603840 #1] INFO -- : yarn install v1.22.22
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

I, [2024-06-05T17:24:31.604648 #1] INFO -- : Terminating async processes
I, [2024-06-05T17:24:31.604696 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/13/bin/postmaster -D /etc/postgresql/13/main pid: 36
2024-06-05 17:24:31.605 UTC [36] LOG: received fast shutdown request
I, [2024-06-05T17:24:31.605048 #1] INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 98
98:signal-handler (1717608271) Received SIGTERM scheduling shutdown...
2024-06-05 17:24:31.608 UTC [36] LOG: aborting any active transactions
2024-06-05 17:24:31.612 UTC [36] LOG: background worker "logical replication launcher" (PID 51) exited with exit code 1
2024-06-05 17:24:31.612 UTC [46] LOG: shutting down
2024-06-05 17:24:31.628 UTC [36] LOG: database system is shut down
98:M 05 Jun 2024 17:24:31.702 # User requested shutdown...
98:M 05 Jun 2024 17:24:31.702 * Saving the final RDB snapshot before exiting.
98:M 05 Jun 2024 17:24:31.703 * DB saved on disk
98:M 05 Jun 2024 17:24:31.703 # Redis is now ready to exit, bye bye...

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse &amp;&amp; su discourse -c 'yarn install --frozen-lockfile &amp;&amp; yarn cache clean' failed with return #&lt;Process::Status: pid 401 exit 1&gt;
Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"yarn", "cmd"=>["if [\"$version\" != \"tests-passed\"]; then\n rm -rf app/assets/javascripts/node_modules\nfi", "su discourse -c 'yarn install --frozen-lockfile &amp;&amp; yarn cache clean'"]}
bootstrap failed with exit code 1
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
b8046f40c39734eb8318b7f868a92127b963e33f1970d43bb122c1c650107e7a

```

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [5 Junho , 2024 19:21 UTC](https://meta.discourse.org/t/unable-to-reinstall-discourse/310691/2 "2024-06-05T19:21:11Z")

</div>

Você já tentou várias vezes, fez várias reconstruções e talvez o DNS não esteja apontando para o seu servidor? Minha suspeita é que você solicitou um certificado várias vezes e ele falhou devido a um erro de DNS ou proxy intermediário, e agora você precisará esperar uma semana. Você pode tentar um subdomínio diferente ou adicionar um segundo endereço ao certificado (não importa qual seja), como descrito em [Configurar Let’s Encrypt com vários domínios / redirecionamentos](https://meta.discourse.org/t/set-up-let-s-encrypt-with-multiple-domains-redirects/56685).

Você executou `./discourse-setup`? Ele passou no teste de DNS no início?
