Unable to restore backup


#1

Hey there,

I’m hosting a Discourse for a small community, which is running now for about half a year. However, before moving to DC we used a phpBB. In order to keep everything running, I decided to import the old php-board into a new and freshly installed DC, which worked totally fine so far.

After a few weeks, we decided to import another phpBB-board of a second community, since we want to have all at one place. Before doing so, I asked at the phpBB-Importer thread if it’s possible to import a second board to a running DC ( Importing from phpBB3 ). Unfortnuately, I forgot to run the SQL statements as mentioned in this thread. So I was running the import, which went well so far but after completion, hardly no new posts etc. appear. Only the user list became longer. The most critical thing by now is that no one is able to login anymore, except of a few, which were already logged in or never logged out. Luckily this is also me.

Then, I tried to import a backup and restore the old DC which failed. Anyone having an idea on what to do next? I would like to restore to the point before importing with the backup.


(Jay Pfaffman) #2

You should be able to restore the backup. Is there enough disk space?

If you can’t log in you can restore from the command line.


(Gerhard Schlager) #3

The main problem is, that you can’t restore a backup.
Are you getting an error message or is there an error in the log file?
It’s quite hard to help you without further information.


#4

Hi,

there should be enough disk space remaining. The log file of the failed restoration:restoration_log.txt (61.0 KB)


(Dean Taylor) #5

Have you changed the version from “tests-passed”?

This might be relevant to you:


#6

I haven’t changed anything so far. Regarding your link, do you mean I should delete the current database and rebuild it with my current app.yml by running the statement as metnioned (and like the user @pjv ) ??


(Jay Pfaffman) #7

Was the backup that you are trying to restore created by the Discourse instance that you are trying to restore it to?


#9

Yes, created by Discourse instance before I started the import etc.


(Jay Pfaffman) #10

How did it fail? What was the error?


#11

I posted the full log file above, but I can’t locate the problem:

[2017-09-11 19:21:52] CREATE TRIGGER
[2017-09-11 19:21:53] Enabling readonly mode...
[2017-09-11 19:21:53] Pausing sidekiq...
[2017-09-11 19:21:53] Waiting for sidekiq to finish running jobs...
[2017-09-11 19:21:53] Switching schemas... try reloading the site in 5 minutes, if successful, then reboot and restore is complete.
[2017-09-11 19:21:53] Migrating the database...
[2017-09-11 19:21:57] EXCEPTION: 

No migration with version number 20170831180419

(Jay Pfaffman) #12

Oh. Right. Sorry.

That’s very strange. I’d rebuild and try to restore again. It’s a bit like rebooting and hoping that something different will happen, but there’s no obvious solution.


#13

hmmm…

root@Ubuntu-1604-xenial-64-minimal ~ # /var/discourse/launcher rebuild
Config file was not found, ensure containers/.yml exists

Available configs ( app, import )

(Jay Pfaffman) #14

./launcher rebuild app


#15

Well, it came back to life. I don’t know what happend at the first attempt, but it’s running now. thanks!!

case closed