Unable to send private message to a group


#1

Hi,

I have created a group and added 15 folks in it.
Group name: mod1

I am trying to send a private message to this group.
But its not working.

Anyone know why?


(Joshua Rosenfeld) #2

Hey again @nixie, can you be more specific? What exactly do you mean by “its not working”?

Without any details to work with, my first guess would be to check the setting Who can message and @mention this group? in /admin/groups/custom/mod1


#3

Hi @jomaxro

Who can message (is set correctly)
image

What I tried:

  1. Sent a private message to this group.
  2. Accessed the profile of one of the group members. Checked his pm box - the message was not there in his pm box

(Joshua Rosenfeld) #4

Hmm, so you composed and sent the message without issue, but the PM is not appearing for the group member?

If you go to your sent folder in /my/messages/sent does the PM appear there? Who is listed in the recipient’s list?

Another thought, group messages go to their own inbox, not the user’s primary inbox. For example, if a message is sent to Staff it appears in the Staff inbox, not my personal inbox:
image


#5

I didn’t know that there was a “separate inbox for groups”.

Mistake I did:
I was checking in the normal inbox.

What had to be done:
I had to check for the message in the “group inbox”

Thanks.


#6

Is there any way to display the group message also in the normal inbox?
Also - a notification is NOT sent when a message is received in the group inbox.
(But notifications are received in the portal when we receive a pm in normal inbox)


(Joshua Rosenfeld) #7

No there isn’t currently.

That means the user is tracking the group inbox not watching it. If they watch it they’ll be notified. There’s previous discussion on this, try a search (I’m away from my computer or I’d look…)


#8

When we receive a pm in “Group Inbox”

  1. I’d like to receive a notification exactly the same way I receive a notification for a pm in normal inbox

ALSO, something which is even better:

  1. I’d like the “group private message” to be gone directly to the “normal pm inbox”

Reason:
I was in an impression that I’m quite a techie guy. But still I missed this. I’ve been using discourse for months now and I couldn’t figure this out myself. My moderators aren’t as good as me. So, I’m sure no one is going to notice it. This is why I requested, it’d be GREAT if someone can help me with “above 2 suggestions”


(Joshua Rosenfeld) #9

OK, I found the topic I mentioned before, Watching group PMs by default. Post #20 is what is of interest, the group you created should be watched by default, unless you changed the Default notification level for group messages setting.

This would need to be a plugin. Groups are very intentionally separate from the personal inbox, not only so they can have a different notification state if wanted, but so there’s a clear distinction between the two different types of messages. With a group inbox, once something is archived it’s archived for the entire group. Makes it easier to see what’s “current” or not.