Unable to start docker service (latest step)


#1

Hi all,

I’m trying to install Discourse and I’m blocked at the latest step so ./launcher start app and I get this error message:

which: no docker.io in (/root/.nvm/versions/node/v6.9.5/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/opt/cpanel/composer/bin:/root/bin)

starting up existing container

  • /usr/bin/docker start app
    Error response from daemon: driver failed programming external connectivity on endpoint app (ebbc0f3d113059f4cf4ab7647e967144b7eb0fdf4cccbc59534bc38728b064f8): Error starting userland proxy: listen tcp 0.0.0.0:443: bind: address already in use
    Error: failed to start containers: app

I use Litespeed for the other domains but apparently, there is an issue with the port 443 I don’t kno see below:

tcp6 0 0 ::1:443 :::* LISTEN 15057/litespeed (ls

I don’t want to break the other website so how do I solve this please cause it is the latest step…

I tried to start the docker service but I get this error message:

Redirecting to /bin/systemctl start docker.service

I ran yum update (because I’m on Centos) and installed the latest kernel and tried again but same result.
So I presume, the issue comes from the docker service I’m unable to start?

Please help cause I’m on the latest step. :frowning:

PS: I don’t use Firewalld


(Vinoth Kannan) #2

Do you have other websites installed in the same instance? If yes then read here Running other websites on the same machine as Discourse


#3

Sorry but this is too geek for me, can you please elaborate? I can execute a few commands via SSH but I’m not an expert or coder or system admin…

I’m on Centos so I use yum and not apt-get.
As explained above, I use Litespeed by default and I have 2 other websites…

To be honest, I tried yesterday to install NodeBB but without success because I had to install Ngynx and a lot of things…
That’s why I’m here and trying to install discourse…

I follow the steps via a tuto on Youtube but blocked at the latest step (see above error message).


(Felix Freiberger) #4

If you’re already running sites on your host, you will need special configuration for this to work.

The easiest way forward is to install Discourse on a new, dedicated VM (e.g. at DigitalOcean). This will then be a typical setup, so being able to follow the install instructions should be enough to get this up and running :slight_smile:

If you insist on installing Discourse on your existing host, you’ll have to follow the spirit of the instructions in the topic @vinothkannans linked to, but the details will differ. This is a more advanced setup, so I’d recommend that you go for the dedicated host instead.