Unable to undo "censoring a word"


#1

Hi,

Now we have a separate “watched words” section in the admin panel from where we can censor certain words and replace it with *****

But I censored a word before this section was implemented.
Now I want to undo my action and unblock those words.
I’m not finding a way to do that.

Please assist.

NOTE:
The first time I censored those words - I think I did it by going to admin -> settings - > (either posting or spam)
But now - I’m not finding that setting there anymore.
(I’m guessing its because of the newly implemented “watched words” section

@team
Please assist. I’m sure this will be of help to a wider audience.


(Jeff Atwood) #2

I think all you need to do is

  • remove the relevant word settings from Logs, Watched Words

  • Rebuild the HTML on the post using the admin wrench action on that post (it is behind the ellipsis button)


#3

@codinghorror
Thanks for the prompt response.

But I’m not talking about a particular post that was created in the past. I’m fine with that.
The problem that I’m facing is that - I’m not able to use “that word” in a new or old post. Its getting censored. I’m not finding any way to remove the censor from that word (that I censored like 2-3 months ago).

Under Watched Words - > Its not there. (Reason: I censored those 2-3 words well before this section was implemented in the admin panel. Previously there was a different setting for this under settings. Its no more there)


(Jeff Atwood) #4

Oh I see, @neil any advice here?


(Jay Pfaffman) #5

What he needs is this: Rebake all posts matching a pattern


(Jeff Atwood) #6

Not exactly, read his last post closely.


(Neil Lalonde) #7

Not sure I"m following. Rebaking doesn’t help with this.

Censored words were migrated to the watched words lists in admin. You should see them there.

Enable show words, go to the Censor section, and click the x’s to delete the words you don’t want to censor anymore. Or if you know the words, search for them. Based on the title of this topic, you’re saying that the censoring is still happening, so they must be there.


#8

Oops, no, that’s not what I want.
I’m not really worried about the existing posts. I’m fine the way they are.

I’ve censored this word “abc” - for some reason (because a guy was spamming)
Now, the guy has stopped coming to the site. And everything is good.
I no more want to censor the word "abc"
How to do it?

Going to admin -> settings -> watched words - will not work - because nothing is showing up there. Reason: I did not censor this word using “watched words” section. This section was implemented very recently. When I censored that word - this section was there in the admin panel. I censored this word in admin-> settings - and from there “posting” I’m guessing - but that particular setting is no more there (since we now have the “watched words” section)


#9

@neil
Yes, previously it was “censored words” or something.
Which was then migrated to “watched words” section.

I did checked the new “watched words” section. I clicked on “show words” - BUT, its not showing the word that I censored using the “old version - censored words section”


#10

@neil
is correct.
It was there.
I missed it the first time.
Sorry for the trouble.


(Jeff Atwood) #11