# Unable to upgrade to PostgreSQL 15/

**URL:** https://meta.discourse.org/t/unable-to-upgrade-to-postgresql-15/354397
**Category:** Self-hosting
**Created:** [February 25, 2025, 12:04pm UTC](https://meta.discourse.org/t/unable-to-upgrade-to-postgresql-15/354397 "2025-02-25T12:04:33Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [February 25, 2025, 12:50pm UTC](https://meta.discourse.org/t/unable-to-upgrade-to-postgresql-15/354397/2 "2025-02-25T12:50:18Z")

</div>

> [@glorioustn](#):
>
> ```plaintext
> popen failure: Cannot allocate memory
> 
> ```

This is perhaps the most serious - you need more RAM or you need to add swap.

Please post the output of these quick diagnostics:

> [@Failed to bootstrap on first install](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475/6):
>
> ```plaintext
> cat /etc/lsb-release
> uptime
> df -h /
> free
> swapon
> vmstat 5 5
> dmesg|egrep -i "memory|oom|kill"
> ps auxrc
> 
> ```

---

_[View the full topic](https://meta.discourse.org/t/unable-to-upgrade-to-postgresql-15/354397)._
