Uncategorized badge is not shown on pinned topics


#1

Hi,

I think I have discovered a bug according to the setting suppress uncategorized badge.

What I have done:

  • Renamed Uncategorized to Notopic.
  • Disabled suppress uncategorized badge as I want to see the badge.

What’s the problem?

The Notopic badge is not shown on pinned topics. Other badges ares shown on pinned topics. The badge should be shown on pinned topics as well.

Discourse Version

1.2.0.beta1

Screenshots

Every Screenshot is made on the Latest page.

Notopic pinned no badge

Another pinned topic with badge

Notopic unpinned with badge


(Jeff Atwood) #2

Nope, not a bug, this is by design. Pinned topics with no category (uncategorized) have extended descriptions.

Originally the only way you could make a globally pinned topic was by putting it in the uncategorized category.


#3

But this behaviour is really inconsistent, isn’t it? I have disabled the suppress uncategorized badge option in the settings so the badge should be shown on all topics. The most confusing part is that the badges of other pinned topics (extended descriptions as well) are shown.

edit: I am confused. The badge is shown on my mobile phone rather than on my desktop pc. I have tested three different browsers with cleaned cache on my computer (firefox, chrome, qupzilla).


(Jeff Atwood) #4

Sorry, this is not the way it is designed to work. Uncategorized means the pinned topic gets the right to span that column, so that you have more room for the description. Originally only topics with no category could be globally pinned – in fact that’s how you used to indicate a global pin, by specifiying no category. That was the only way to indicate a global pin.

The mobile display issue might be a bug and we’ll get to that in time.


(Jeff Atwood) #5