Unresponsive server less than two days after launching app?


(Mike) #1

I’m hosting via Digital Ocean (1GB memory with 1GB swap), and running the latest version of Docker:

root@forums:~# docker version
Client version: 1.1.2
Client API version: 1.13

When I initially launched, the app was running perfectly, and I didn’t touch it for 24 hours. I did not integrate discourse into an existing site so the application isn’t getting any traffic whatsoever at this point.

System information as of Sat Jul 26 12:59:26 EDT 2014

System load: 0.0 Processes: 74
Usage of /: 15.5% of 29.40GB Users logged in: 0
Memory usage: 5% IP address for eth0: 107.170.246.170
Swap usage: 0%

MTR test

Host tested: 107.170.246.170
Test performed from: New York, NY
Test performed at: 2014-07-26 17:34:07 (GMT +00:00)

Hop Hostname (IP)
(107.170.246.170)

Country
USA

Loss
80 %

Sent
5

Rcvd
1

Min (ms)
75.502

Avg (ms)
75.502

Max (ms)
75.502

Any ideas why I am experiencing these latency issues? I have an open ticket with Digital Ocean but haven’t heard back from them yet.


#2

Can you provide a link to your discourse site?

Is the site loading eventually or not because you mention that it is unresponsive in the title but you say that you are experiencing latency issues, so that translates to me ‘slow load’.

Is it a vanilla install or did you add anything to the admin/content section?

Next…

Have you tried to run:
cd /var/docker/
git pull
./launcher rebuild app
./launcher start app

Git Pull is not required with the newer releases but it doesn’t hurt and I do it out of habit so I can see what has changed.

Let us know.


(Mike) #3

Really appreciate the response, git pull worked like a charm.


#4

My pleasure. Glad it worked.


(Jeff Atwood) #5

80% ping loss, you mean? Sounds like an intermittent connectivity issue, nothing to do with Discourse proper.