Update Discourse / Site unavailable


(Mike) #1

I justr tried to update discourse to 1.9 via putty and ./launcher rebuild app is failing with the following error:

no my site can’t be reached anymore.
Any Ideas?


(Stephen Chung) #2

Does the server have internet access? Seems like it is choking on not being able to pull from Github.


(Mike) #3

Its installed on a Digital Ocean Droplet and the dashboard shows everything is online.


(Stephen Chung) #4

Ah, I see it a bit up. It tries to pull from Github the discourse-narrative-bot but finds that the directory is already there, and it is not empty, so it just sorta dies.

Maybe you have two duplicated lines of the same plugin (in this case discourse-narrative-bot) in your app.yaml? Doesn’t seem so because it pulled in docker_manager just fine before moving onto discourse-narrative-bot.

Maybe you need to enter the container and check what is in the discourse-narrative-bot directory inside plugins?


(Mike) #5

The
- git clone https://github.com/discourse/discourse-narrative-bot.git
is only there once.
Getting lost in translation on your last sentence.


(David Taylor) #6

discourse-narrative-bot is now part of discourse itself. Therefore you can remove the git pull https://github.com/discourse/discourse-narrative-bot.git line from your app.yml file.


(Mike) #7

that worked and everything is up and running again!
Thx!!