Update Docker Assistance - Broken Site

Morning,

It has been the better part of a year since I have updated my site.

Today I logged in through putty, and the error came up that my Docker wasn’t the proper version after running the update commands from the ‘…Manually Update Discourse…’ post:

cd /var/discourse
git pull

So I ran below which caused the site to break:

wget -qO- https://get.docker.com/ | sh

From troubleshooting suggestions in the Site Down After Upgrade post I ran:

docker ps

which shows below, instead of the normal info it would have shown previous to the updated docker.
image

I ran the first step again at this point, ./launcher rebuild app, which netted the same result, site still not loading.

I also tried clearing up space, from the “502 Bad Gateway…” post, as I have never done this since starting the site, but did not seem to help.

Lastly, I restored the droplet on DigitalOcean from 2 days ago, which got the site back running properly. I tried updating the docker again, but was met with the same result.

I’ve done my best to comb through support searches and troubleshoot before posting, but any help at this point would be greatly appreciated.

Let me know any additional info I can provide.

did you try safe mode?

https://yoursite.com/safe-mode

My site displayed a white screen after updating yesterday, and entering safe-mode and disabling the theme worked. Then I went in and updated the theme component that was causing the problem, and I was back in business.

Sometimes I’ve found that just running ./launcher rebuild app a few times ends up doing the trick as well. Or restarting the server first and then rebuilding.

1 Like

Just to clarify, you’re suggesting these steps after I update the Docker again?

It looks like discourse is ‘gone’ when I run the docker upgrade from the step that I showed with ‘docker ps’.

Will the rebuild fix that?

Just to update, I ran:

wget -qO- https://get.docker.com/ | sh

Then:

 cd /var/discourse
./launcher rebuild app

Then, I ran below again and now the site works!

./launcher rebuild app

Thanks for the suggestion. Apologies since it was so simple to just try the rebuild again, but hopefully this post can help others. I assumed it was just broken after running it the first time. Maybe this suggestion could be added to the Manual Update how-to thread.

4 Likes