Update error "Write failed: Broken pipe"


(Sascha Foerster) #1

I tried to update several days ago, but the updater of Discourse in the webinterface got stuck.
So I decided to delete and reinstall docker as well as the images.
I followed the installation instructions, that worked before, but now it waits endlessly and after 10 hours, it just stops:
/var/discourse$ sudo ./launcher bootstrap app

I, [2015-02-09T22:55:41.872797 #38]  INFO -- : > cd /var/www/discourse && gem update bundler
I, [2015-02-09T22:56:02.444003 #38]  INFO -- : Updating installed gems
Updating bundler
Successfully installed bundler-1.7.13
Gems updated: bundler

I, [2015-02-09T22:56:02.444568 #38]  INFO -- : > cd /var/www/discourse && chown -R discourse /var/www/discourse
I, [2015-02-09T22:56:21.247307 #38]  INFO -- : 
I, [2015-02-09T22:56:21.253784 #38]  INFO -- : > cd /var/www/discourse && su discourse -c 'bundle install --deployment --verbose --without test --without development'
Write failed: Broken pipe

Could you please help me to debug the installation?


Can't rebuild. Freezes midway through
(Jonathan Lin) #2

Try running again over a stable connection? The SSH connection probably dropped.


(Sascha Foerster) #3

Thank you, that helped. It took an endless time to install, but now I only have problems with my ports and nginx (but I will sole them myself now).