# Update Error

**URL:** https://meta.discourse.org/t/update-error/323924
**Category:** Self-hosting
**Created:** [August 29, 2024, 6:49am UTC](https://meta.discourse.org/t/update-error/323924 "2024-08-29T06:49:11Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![fidelio](https://avatars.discourse-cdn.com/v4/letter/f/f1d935/32.png) [@fidelio](https://meta.discourse.org/u/fidelio)
#### Post date: [August 29, 2024, 6:49am UTC](https://meta.discourse.org/t/update-error/323924/1 "2024-08-29T06:49:11Z")

</div>

I tried to update to 3.4.0 last night and the update keeps failing. Can’t find an obvious plug-in error and there appears to be enough memory also…

```plaintext

==================== SERIOUS PROBLEM!!!! ====================

app not running!

Attempting to rebuild

==================== REBUILD LOG ====================

x86_64 arch detected.

WARNING: containers/app.yml file is world-readable. You can secure this file by running: chmod o-rwx containers/app.yml

Ensuring launcher is up to date

Fetching origin

Launcher is up-to-date

Stopping old container

+ /usr/bin/docker stop -t 600 app

app

2.0.20240825-0027: Pulling from discourse/base

Digest: sha256:6de68cb49198b5281f79ed9401b3fe818c854d220dcf0238549fe2f2adb19146

Status: Image is up to date for discourse/base:2.0.20240825-0027

/usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups.rb

/usr/local/bin/pups --stdin

I, [2024-08-29T06:27:54.954308 #1] INFO -- : Reading from stdin

I, [2024-08-29T06:27:54.967006 #1] INFO -- : File > /etc/service/postgres/run chmod: +x chown:

I, [2024-08-29T06:27:54.972778 #1] INFO -- : File > /etc/service/postgres/log/run chmod: +x chown:

I, [2024-08-29T06:27:54.977868 #1] INFO -- : File > /etc/runit/3.d/99-postgres chmod: +x chown:

I, [2024-08-29T06:27:54.983048 #1] INFO -- : File > /root/install_postgres chmod: +x chown:

I, [2024-08-29T06:27:54.988576 #1] INFO -- : File > /root/upgrade_postgres chmod: +x chown:

I, [2024-08-29T06:27:54.988882 #1] INFO -- : Replacing data_directory = '/var/lib/postgresql/13/main' with data_directory = '/shared/postgres_data' in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.989890 #1] INFO -- : Replacing (?-mix:#?listen_addresses *=.*) with listen_addresses = '*' in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.992525 #1] INFO -- : Replacing (?-mix:#?synchronous_commit *=.*) with synchronous_commit = $db_synchronous_commit in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.993361 #1] INFO -- : Replacing (?-mix:#?shared_buffers *=.*) with shared_buffers = $db_shared_buffers in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.994078 #1] INFO -- : Replacing (?-mix:#?work_mem *=.*) with work_mem = $db_work_mem in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.994692 #1] INFO -- : Replacing (?-mix:#?default_text_search_config *=.*) with default_text_search_config = '$db_default_text_search_config' in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.996207 #1] INFO -- : Replacing (?-mix:#?checkpoint_segments *=.*) with checkpoint_segments = $db_checkpoint_segments in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.996893 #1] INFO -- : Replacing (?-mix:#?logging_collector *=.*) with logging_collector = $db_logging_collector in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.998006 #1] INFO -- : Replacing (?-mix:#?log_min_duration_statement *=.*) with log_min_duration_statement = $db_log_min_duration_statement in /etc/postgresql/13/main/postgresql.conf

I, [2024-08-29T06:27:54.998824 #1] INFO -- : Replacing (?-mix:^#local +replication +postgres +peer$) with local replication postgres peer in /etc/postgresql/13/main/pg_hba.conf

I, [2024-08-29T06:27:54.999520 #1] INFO -- : Replacing (?-mix:^host.*all.*all.*127.*$) with host all all 0.0.0.0/0 md5 in /etc/postgresql/13/main/pg_hba.conf

I, [2024-08-29T06:27:55.000423 #1] INFO -- : Replacing (?-mix:^host.*all.*all.*::1\/128.*$) with host all all ::/0 md5 in /etc/postgresql/13/main/pg_hba.conf

I, [2024-08-29T06:27:55.001096 #1] INFO -- : > if [-f /root/install_postgres]; then

/root/install_postgres && rm -f /root/install_postgres

elif [-e /shared/postgres_run/.s.PGSQL.5432]; then

socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1

fi

I, [2024-08-29T06:27:55.067844 #1] INFO -- : Generating locales (this might take a while)...

Generation complete.

postgres already running stop container

FAILED

--------------------

Pups::ExecError: if [-f /root/install_postgres]; then

/root/install_postgres && rm -f /root/install_postgres

elif [-e /shared/postgres_run/.s.PGSQL.5432]; then

socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1

fi

failed with return #<Process::Status: pid 16 exit 1>

Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'

exec failed with the params {"tag"=>"db", "cmd"=>"if [-f /root/install_postgres]; then\n /root/install_postgres && rm -f /root/install_postgres\nelif [-e /shared/postgres_run/.s.PGSQL.5432]; then\n socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1\nfi\n"}

bootstrap failed with exit code 1

**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.

./discourse-doctor may help diagnose the problem.

afa7edec7b05a0d8269e150cef76c0f3d66c0ec9ff17378f8202d2e10b81ded1

==================== END REBUILD LOG ====================

```

```plaintext
              total used free shared buff/cache available
Mem: 4039588 282424 1478380 44144 2278784 3421444
Swap: 0 0 0

```

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [August 29, 2024, 8:38am UTC](https://meta.discourse.org/t/update-error/323924/2 "2024-08-29T08:38:30Z")

</div>

I had a 4gb instance run out of memory yesterday so I would add swap, though that does not appear to be the issue here.

It looks like postgres is already running. You have just the app.yml and not also a data.yml?

---

<div class="post-metadata">

### Author: ![fidelio](https://avatars.discourse-cdn.com/v4/letter/f/f1d935/32.png) [@fidelio](https://meta.discourse.org/u/fidelio)
#### Post date: [August 29, 2024, 11:42am UTC](https://meta.discourse.org/t/update-error/323924/3 "2024-08-29T11:42:57Z")

</div>

Hi Jay,  
How do I access or rebuild the data.yml?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [August 29, 2024, 11:45am UTC](https://meta.discourse.org/t/update-error/323924/4 "2024-08-29T11:45:43Z")

</div>

I suspect that you don’t have one, and if that’s the case, then I don’t have any ideas of what the postgres issue is.

---

<div class="post-metadata">

### Author: ![fidelio](https://avatars.discourse-cdn.com/v4/letter/f/f1d935/32.png) [@fidelio](https://meta.discourse.org/u/fidelio)
#### Post date: [August 29, 2024, 7:21pm UTC](https://meta.discourse.org/t/update-error/323924/5 "2024-08-29T19:21:10Z")

</div>

After rebooting the droplet, the rebuild went a little further and I ended up with same issue as posted here: [PostgreSQL Stuck During Rebuilding - #15 by haroldfy](https://meta.discourse.org/t/postgresql-stuck-during-rebuilding/323434/15)

I got back to the previous **3.4.0.beta1-dev** version of the forum with `./launcher start app`.

Might wait for the next release and/or try and update to Ubuntu 20.04.6 LTS.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [August 29, 2024, 10:10pm UTC](https://meta.discourse.org/t/update-error/323924/6 "2024-08-29T22:10:03Z")

</div>

I would spin up a new vm with a new os rather than attempting an upgrade of the os.

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [August 30, 2024, 12:16pm UTC](https://meta.discourse.org/t/update-error/323924/7 "2024-08-30T12:16:52Z")

</div>

Let’s close this one off and keep the discussion to the other topic. 👍

> [@PostgreSQL Stuck During Rebuilding](https://meta.discourse.org/t/postgresql-stuck-during-rebuilding/323434):
>
> Hello everyone, I’m running into an issue with PostgreSQL startup issue when I tried to rebuild my app, and I’m hoping to get some help. Here’s the log, it has been stuck on this status for more than 30 mins. Status: Image is up to date for discourse/base:2.0.20240825-0027 docker.io/discourse/base:2.0.20240825-0027 /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups.rb /usr/local/bin/pups --stdin I, [2024-08-26T17:16:15.344712 #1] INFO -- : Reading from stdin I, [2024-08-26T17:16:15.3579…

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [August 30, 2024, 12:16pm UTC](https://meta.discourse.org/t/update-error/323924/8 "2024-08-30T12:16:57Z")

</div>


