Update failed - Failed to Bootstrap


(Miroslav Schlossberg) #1

I tried to update my Discourse instance running on Digital Ocean with git pull and ./launcher rebuild app.

I got this error:

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile' failed with return #<Process::Status: pid 376 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}
0965177baaf23a12011e1d9fd212706cee61979f71e99964e095a38737b94718
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

I reckon it’s because of this errors:

rake aborted!
Barber::PrecompilerError: Pre compilation failed for: <div class='container'>
  {{custom-html "top"}}
  {{Discourse.globalNotice}}
</div>

And/or this error:

ExecJS::ProgramError: Error: Assertion Failed: Using `{{controller}}` or any path based on it ('javascripts/discourse_user_directory/templates/directory' @ L14:C18) has been removed in Ember 2.0
new Error (native)
Error.EmberError ((execjs):9091:21)
assert ((execjs):6024:13)
Object.assert ((execjs):8855:34)
assertPath ((execjs):16427:22)
assertPaths ((execjs):16422:7)
assertHash ((execjs):16411:7)
(execjs):16397:7
Walker.visit ((execjs):23457:7)
ElementNode ((execjs):23473:16)

Full log: Etherpad

Tried restart, and hen again ./launcher rebuild app (like suggested in this topic), but it didn’t help.

Any help appreciated. Thanks!


(Jeff Atwood) #2

Did you disable all third-party plugins before rebuilding? That’s the most common reason.


(Miroslav Schlossberg) #3

Hi Jeff, unfortunately no. I’ve first run update like I usually do via web /admin/upgrade/. I had to update docker (done), then checklist (done), and lastly discourse (failed). So I went to rebuild via terminal.

Is there a way to check what plugins I have and disable them from terminal (in configuration file or else)?


(cpradio) #4

Yes, they would be in your app.yml, just comment anything out that doesn’t start with github.com/discourse (to start), and then re-enable them one by one. Until you find the culprit.