Update failed, now showing Oops

The other day I installed the latest update through the administrator dashboard. It’s a brand-new Discourse installation, and I haven’t done more than put in a few categories and a couple of posts. There aren’t even any other users yet.

When I ran the update, after a few minutes, I got the message that the update had failed. Now, when I try to get on to the site, I get the “Oops” message. Trying to use the safe mode gives the same results.

As an extreme newbie to Discourse and the whole administrator thing (although I’ve been an applications programmer for decades), I find I haven’t any idea what to do next.

Can someone please suggest a next step?

Thanks

Dave G

Have you tried to rebuild over SSH since?

cd /var/discourse
./launcher rebuild app

Was this a straight install using the cloud install guide from the official source? Were there any plugins added to the install?

4 Likes

This was an official install. I paid the $99 to have it installed. There were no plugins added, to my knowledge.

I’ve tried logging into the server using putty on a Windows 7 machine and get the error “Disconnected: No supported authentication methods available (server sent publickey)”

When I try the ./admin/upgrade url, I get the message:

You are running an old version of the Discourse image.
Upgrades via the web UI are disabled until you run the latest image.

To do so log in to your server using SSH and run:

    cd /var/discourse
    ./launcher rebuild app

Since putty fails to log in, I haven’t a direction to go from here.

Thanks for whatever help you can give.

For the old $99 self-support installs they are indeed 100% self support. We can recommend Jay at https://literatecomputing.com he does excellent work.

2 Likes