# Update failure

**URL:** https://meta.discourse.org/t/update-failure/355507
**Category:** Support
**Created:** [March 3, 2025, 7:33pm UTC](https://meta.discourse.org/t/update-failure/355507 "2025-03-03T19:33:44Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![lunarspectrum](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/lunarspectrum/32/448371_2.png) [@lunarspectrum](https://meta.discourse.org/u/lunarspectrum)
#### Post date: [March 3, 2025, 7:33pm UTC](https://meta.discourse.org/t/update-failure/355507/1 "2025-03-03T19:33:44Z")

</div>

Hello,

I’m having a failure rebuilding the app.

```plaintext
Get:15 https://apt.postgresql.org/pub/repos/apt bookworm-pgdg/main amd64 Packages [361 kB]
Fetched 10.2 MB in 3s (3,813 kB/s)
Reading package lists...Reading package lists...Stopping PostgreSQL 15 database server: main.

check for "/usr/lib/postgresql/13/bin" failed: No such file or directory

Failure, exiting
-------------------------------------------------------------------------------------
UPGRADE OF POSTGRES FAILED

Please visit https://meta.discourse.org/t/postgresql-15-update/349515 for support.

You can run ./launcher start app to restart your app in the meanwhile
-------------------------------------------------------------------------------------

FAILED
--------------------
Pups::ExecError: if [-f /root/install_postgres]; then
  /root/install_postgres && rm -f /root/install_postgres
elif [-e /shared/postgres_run/.s.PGSQL.5432]; then
  socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1
fi
 failed with return #<Process::Status: pid 18 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec failed with the params {"tag"=>"db", "cmd"=>"if [-f /root/install_postgres]; then\n /root/install_postgres && rm -f /root/install_postgres\nelif [-e /shared/postgres_run/.s.PGSQL.5432]; then\n socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1\nfi\n"}
bootstrap failed with exit code 1

```

Following the provided link [https://meta.discourse.org/t/postgresql-15-update/349515](https://meta.discourse.org/t/postgresql-15-update/349515) and running the manual update procedure also fails. Entering the app and running only `apt-get update` fails, and leads to an error message that leads the same error as in this issue [Debian install fails on Bookworm in FIPS mode · Issue #1096 · docker/docker-ce-packaging · GitHub](https://github.com/docker/docker-ce-packaging/issues/1096)

And indeed, my system is in FIPS mode, and trying to only update `libgcrypt` fails with the same error message as in the GitHub issue above.

Does anyone have any ideas on how to proceed?

Thank you!

-Steve

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 3, 2025, 8:00pm UTC](https://meta.discourse.org/t/update-failure/355507/2 "2025-03-03T20:00:59Z")

</div>

Is your OS beyond end of life?

What version of Docker do you have?

Can you start the existing container with `./launcher start app` or maybe `docker start app`? If so, I’d probably recommend making a backup, spinning up a new VM, installing Discourse, and restoring that backup.

---

<div class="post-metadata">

### Author: ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)
#### Post date: [March 4, 2025, 6:17pm UTC](https://meta.discourse.org/t/update-failure/355507/3 "2025-03-04T18:17:07Z")

</div>

Can you provide the complete log output?

There may be more failures above that we missed that eventually caused this one.

Some more information about your setup would also help:

- what OS is running on the host?
- what setup are you using (i.e. standalone?)

> [@pfaffman](#):
>
> Can you start the existing container with `./launcher start app` or maybe `docker start app`? If so, I’d probably recommend making a backup, spinning up a new VM, installing Discourse, and restoring that backup.

No argument with this. Step #1 should always be “make a backup”.

e.g.:

- take a Discourse backup
- shut down the containers
- move postgres data out of the way
- do a rebuild
- restore the backup

But first we need to know what we’re working with.
