# Update private plugin without rebuilding the application

**URL:** <https://meta.discourse.org/t/update-private-plugin-without-rebuilding-the-application/63286>\
**Category:** Support\
**Created:** [May 24, 2017, 2:44pm UTC](https://meta.discourse.org/t/update-private-plugin-without-rebuilding-the-application/63286 "2017-05-24T14:44:44Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![net\_deamon](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/net_deamon/32/70126_2.png) [@net\_deamon](https://meta.discourse.org/u/net_deamon)\
**Post date:** [July 18, 2017, 7:31pm UTC](https://meta.discourse.org/t/update-private-plugin-without-rebuilding-the-application/63286/6 "2017-07-18T19:31:38Z")

</div>

> [@sam](#):
>
> Not against making /admin/upgrade smarter, feel free to send through a PR in that department.

Hi @sam, I am now working on fixing the plugin. Needed some guidance.

The real problem lies here

`In docker_manager/lib/docker_manager/git_repo.rb (54)`

```
if url =~ /^git/
    # hack so it works with git urls
  url = "https://github.com/#{url.split(":")[1]}"
 end

```

It converts the bitbucket url to github because bitbucket url starts with “git”

`example : git@bitbucket.<account_name>/<plugin_name>.git`

By adding a condition to check for bitbucket works ( and it detects the upgrade version too), but when I try to upgrade, it throws errror “Host key verification failed”

![](https://global.discourse-cdn.com/meta/original/3X/f/3/f3f049ec0cebe2c4dadf882af6474b4d1391b869.png)

Then I came to know that it occurs because we remove the keys from .ssh folder in app.yml file for bitbucket.

But even if I let the ssh keys to be present inside docker container, and run the upgrade, I get the same error.  
Here is the output of **/.ssh/config file**

> Host bitbucket  
> StrictHostKeyChecking no  
> HostName [bitbucket.org](http://bitbucket.org)  
> IdentityFile /root/.ssh/id\_rsa

**I can successfully run the upgrade command inside docker container and upgrade the plugin myself** , but it throws above error when running from /admin/upgrade.

I think it might be because the upgrader is not running as sudo user(correct me if I am wrong).

So can you give me some pointers, on how to proceed

1. Using ssh way ie `git@bitbucket.org:<accountname>/<reponame>.git` and pulling from bitbucket ( this is giving me error “host key verification failed”)
2. Using https way ie `https://<accountname>@bitbucket.org/<accountname>/<reponame>.git`, but I need to somehow provide password and username before upgrading. I think I can add textbox which asks for username and password before starting the upgrade

---

_[View the full topic](https://meta.discourse.org/t/update-private-plugin-without-rebuilding-the-application/63286)._
