# Update problem : Broken Forum

**URL:** https://meta.discourse.org/t/update-problem-broken-forum/222055
**Category:** Self-hosting
**Tags:** server-resources
**Created:** [March 26, 2022, 8:20pm UTC](https://meta.discourse.org/t/update-problem-broken-forum/222055 "2022-03-26T20:20:17Z")
**Posts on this page:** 1
**Showing post:** 20

<div class="post-metadata">

### Author: ![mreach](https://avatars.discourse-cdn.com/v4/letter/m/9d8465/32.png) [@mreach](https://meta.discourse.org/u/mreach)
#### Post date: [April 1, 2022, 4:53am UTC](https://meta.discourse.org/t/update-problem-broken-forum/222055/20 "2022-04-01T04:53:36Z")

</div>

Interestingly I’ve experienced either the same or similar error. Running on Discourse 2.9.0.beta2 and tried to update to ß3. I’ve disabled all plugins except `docker_manager` for `./launcher rebuild app`. Running on an external PGSQL db at version:

```plaintext
$ psql --version
psql (PostgreSQL) 14.1 (Ubuntu 14.1-1.pgdg18.04+1)

```

I can restart the container via `./launcher restart app` following the failure, but when replies return a 500 error.

The end error during rebuild/upgrade is:

```plaintext
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 658 exit 1>
Location of failure: /usr/local/lib/ruby/gems/2.7.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
bootstrap failed with exit code 1
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.

```

The actual meaningful errors above may be found here: [https://p153.p0.n0.cdn.getcloudapp.com/items/jkuvPekN/feb38236-3b84-410e-8fac-d1864d02ba69.txt?v=eb1d15e029cb07a73300d8ec07318876](https://p153.p0.n0.cdn.getcloudapp.com/items/jkuvPekN/feb38236-3b84-410e-8fac-d1864d02ba69.txt?v=eb1d15e029cb07a73300d8ec07318876)

I’m having a hard time believing that this is an actual permission issue and I’m hesitant to give the Discourse DB use super user/root permission to pgsql.

Any further thoughts on what could be going on here with such a recent breakage?

---

_[View the full topic](https://meta.discourse.org/t/update-problem-broken-forum/222055)._
