Update to latest version is not active


(Алексей Копаев) #1

Update to latest version is not active. What could be the reason?
https://site/admin/upgrade


(Joshua Rosenfeld) #2

Have you tried waiting to see if docker_manager has an update? On my instance I have previously needed to complete the docker manager update before I’m able to complete any others…

Edit: Just checked out my instance, and can confirm what I said above. The Discourse update was disabled, and there was a pending docker_manager update. Once I completed the docker_manager update, the button for Discourse became enabled.


(Алексей Копаев) #3

Yes. I tried to wait. But the buttons are still inactive.


(Joshua Rosenfeld) #4

I’m not sure what else to say. Your second screenshot shows that docker_manager is out of date. The current commit is a5ff153. If you’ve waited and it continually says Checking for new version... and never gives you the option to update it, you’ll likely need to do it from the console.

SSH to your server and run the following commands:

cd /var/discourse
git pull
./launcher rebuild app

(Jeff Atwood) #5

You have too many plugins so the http calls to get versions are timing out or are hitting the built in rate limits.

Rebuild from command line.