# Update = ☠

**URL:** https://meta.discourse.org/t/update/285222
**Category:** Self-hosting
**Created:** [November 11, 2023, 11:42pm UTC](https://meta.discourse.org/t/update/285222 "2023-11-11T23:42:48Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 11, 2023, 11:42pm UTC](https://meta.discourse.org/t/update/285222/1 "2023-11-11T23:42:48Z")

</div>

Hi all

I keep up on updates pretty well, seen one was due and did it, the result was no UI except in admin

SSH in and did server updates to be sure all were good, no help

Tried to roll back and got this

 ![image](https://global.discourse-cdn.com/meta/original/4X/e/5/d/e5dffe14ff5123bf85b048692f699c493586550f.png)

Entered [Safe Mode](https://meta.discourse.org/t/53504?silent=true) and got booted, but got a partial UI

 ![image](https://global.discourse-cdn.com/meta/original/4X/e/1/d/e1d7a3f25820750e3a7578b2df3ad2c02be49d2e.png)

Can’t log in, says my username is available and that my email does not exist

I could use some help please and thank you

* * *

edit, rebooted server and got

 ![image](https://global.discourse-cdn.com/meta/original/4X/b/0/e/b0e053a8da8eb3054139857202fce7da71f31089.png)

not swayed I went to register, figured a back up was due now

 ![image](https://global.discourse-cdn.com/meta/original/4X/3/b/b/3bb662ec8326e2abf136147276dc528cf0b2a55d.png)

no joy there either

* * *

edit, refreshing a different window I seemed to be able to register

 ![image](https://global.discourse-cdn.com/meta/original/4X/8/1/1/81178f14ab2128f8d6fb95c6c1abf3b44222ccfb.png)

then

 ![image](https://global.discourse-cdn.com/meta/original/4X/9/2/3/923b79e7404c09774f599a34e91d55dd9ba7e2f9.png)

still no joy

* * *

SSH and things still appear as they were

 ![image](https://global.discourse-cdn.com/meta/original/4X/2/5/c/25cf444458f9380c5fdccdee7fdc9181f2684a5e.png)

* * *

edit

![image](https://global.discourse-cdn.com/meta/original/4X/e/d/0/ed06bfb3c9b2af5e703f88ad6e336c5737b97e7a.png)

 ![image](https://global.discourse-cdn.com/meta/original/4X/e/6/f/e6fcd4743cb970b6643c354472a1188d571bb77a.png)

 ![image](https://global.discourse-cdn.com/meta/original/4X/3/0/5/305f9e7b203e5c9f1ca88e7f76ea3e9f39beb942.png)

 ![image](https://global.discourse-cdn.com/meta/original/4X/3/e/2/3e2639ffb227f127010efcd73472525ffa2f4775.png)

```plaintext
DISCOURSE DOCTOR Sun Nov 12 01:54:06 UTC 2023
OS: Linux ip-10-0-159-37 6.2.0-1015-aws #15~22.04.1-Ubuntu SMP Fri Oct 6 21:37:24 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Found containers/app.yml

==================== YML SETTINGS ====================
DISCOURSE_HOSTNAME=forum.full30.com
SMTP_ADDRESS=smtp.sendgrid.net
DEVELOPER_EMAILS=REDACTED 
SMTP_PASSWORD=REDACTED 
SMTP_PORT=587
SMTP_USER_NAME=apikey
LETSENCRYPT_ACCOUNT_EMAIL=REDACTED LETSENCRYPT_ACCOUNT_EMAIL

==================== DOCKER INFO ====================
DOCKER VERSION: Docker version 24.0.7, build afdd53b

DOCKER PROCESSES (docker ps -a)

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
0be0150fecde local_discourse/app "/sbin/boot" 5 months ago Exited (5) 11 minutes ago app

==================== SERIOUS PROBLEM!!!! ====================
app not running!
Attempting to rebuild
==================== REBUILD LOG ====================
x86_64 arch detected.
Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 600 app
app
2.0.20231023-1945: Pulling from discourse/base
Digest: sha256:2b0eb484d20888cc2daadb690dcfa73522105650c1420212e99345a36a424d77
Status: Image is up to date for discourse/base:2.0.20231023-1945
docker.io/discourse/base:2.0.20231023-1945
/usr/local/lib/ruby/gems/3.2.0/gems/pups-1.2.1/lib/pups.rb
/usr/local/bin/pups --stdin
I, [2023-11-12T01:54:13.829288 #1] INFO -- : Reading from stdin
I, [2023-11-12T01:54:13.834181 #1] INFO -- : > locale-gen $LANG && update-locale
I, [2023-11-12T01:54:13.862453 #1] INFO -- : Generating locales (this might take a while)...
Generation complete.

I, [2023-11-12T01:54:13.862638 #1] INFO -- : > mkdir -p /shared/postgres_run
I, [2023-11-12T01:54:13.865023 #1] INFO -- : 
I, [2023-11-12T01:54:13.865390 #1] INFO -- : > chown postgres:postgres /shared/postgres_run
I, [2023-11-12T01:54:13.867489 #1] INFO -- : 
I, [2023-11-12T01:54:13.867791 #1] INFO -- : > chmod 775 /shared/postgres_run
I, [2023-11-12T01:54:13.869643 #1] INFO -- : 
I, [2023-11-12T01:54:13.869925 #1] INFO -- : > rm -fr /var/run/postgresql
I, [2023-11-12T01:54:13.871930 #1] INFO -- : 
I, [2023-11-12T01:54:13.872203 #1] INFO -- : > ln -s /shared/postgres_run /var/run/postgresql
I, [2023-11-12T01:54:13.874058 #1] INFO -- : 
/tmp/discourse-debug.txt

```

---

<div class="post-metadata">

### Author: ![simon](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/simon/32/339122_2.png) [@simon](https://meta.discourse.org/u/simon)
#### Post date: [November 12, 2023, 3:32am UTC](https://meta.discourse.org/t/update/285222/2 "2023-11-12T03:32:22Z")

</div>

This seems significant:

```plaintext
Warning: Could not create server TCP listening socket *:6379: bind: Address already in use

```

I think Redis is expected to run on port 6379.

Could not being able to create the Redis server cause issues with migrations?

```plaintext
Error: relation "summary_sections" already exists

```

For some reason the migration to create the `summary_sections` table is getting run again. Are there any other duplicate table errors in your logs?

I guess the other question is, do you have a recent backup file?

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 12, 2023, 12:17pm UTC](https://meta.discourse.org/t/update/285222/3 "2023-11-12T12:17:09Z")

</div>

> [@simon](#):
>
> do you have a recent backup file

lol, yep, I’d pretty much guess the same, answer sadly is looking into my server I see Nov 5th as most recent, as I can not log into admin I can not see if maybe there’s a newer one created by Discourse

But… this is this morning,

![forum](https://global.discourse-cdn.com/meta/original/4X/9/a/2/9a212c1dd7f252eb5ae6dc7fb84834b82c5dbcc3.gif)

If I can not log into the admin dash to do a back-up then I simply don’t know what to do?

Thanks for the reply, I hope I can get going again quickly even if on a week old back up.

Robert

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 12, 2023, 12:20pm UTC](https://meta.discourse.org/t/update/285222/4 "2023-11-12T12:20:28Z")

</div>

> [@simon](#):
>
> Are there any other duplicate table errors in your logs?

I’m so unfamiliar with logs, I’ve been dong this for five years with so few and easily repairable issues that there was no reason to be, and I don’t have a tech team to ask, is it something you can walk me through to get and post and will it be redacted like the Doctor file if I do upload?

---

<div class="post-metadata">

### Author: ![anon65426961](https://avatars.discourse-cdn.com/v4/letter/a/34f0e0/32.png) [@anon65426961](https://meta.discourse.org/u/anon65426961)
#### Post date: [November 12, 2023, 12:24pm UTC](https://meta.discourse.org/t/update/285222/5 "2023-11-12T12:24:25Z")

</div>

I also experienced a problem with this most recent update for a new site, may have accidentally interrupted the install and then the site reported both that it had been updated and at the same time needed to be updated urgently, but could not be updated because it had just completed the most recent update.

Rebuilding the app from console solved this, did not have to recover from backup.

Would be good to know how to re-launch site from backup also don’t know how to do that.

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 12, 2023, 12:54pm UTC](https://meta.discourse.org/t/update/285222/6 "2023-11-12T12:54:52Z")

</div>

just to try again I did

```plaintext
cd /var/discourse
git pull
./launcher rebuild app

```

and again got

 ![image](https://global.discourse-cdn.com/meta/original/4X/c/c/1/cc1c913c99537a1522cd62edb29fefa767375f50.png)

errors/warnings as follow

 ![image](https://global.discourse-cdn.com/meta/original/4X/8/c/6/8c668cade39f97ee760ca528a7a997f5cc9b8a14.png)

![image](https://global.discourse-cdn.com/meta/original/4X/f/1/9/f19d0c98a3ca07bc4a7fca1c54cf20ffc6fbc5af.png)

 ![image](https://global.discourse-cdn.com/meta/original/4X/a/9/b/a9b84790b2806b8a36629c7d692fbd7fda0e5ea6.png)

 ![image](https://global.discourse-cdn.com/meta/original/4X/2/4/5/2459d82a7f166ca309a059ffbb3786de82aacd6c.png)

 ![image](https://global.discourse-cdn.com/meta/original/4X/f/f/4/ff4443528f3ee7d0765b957797e0c73a4892b5f4.png)

Doctor did not help again, I kept its report but nothing new in it

---

<div class="post-metadata">

### Author: ![anon65426961](https://avatars.discourse-cdn.com/v4/letter/a/34f0e0/32.png) [@anon65426961](https://meta.discourse.org/u/anon65426961)
#### Post date: [November 12, 2023, 1:11pm UTC](https://meta.discourse.org/t/update/285222/7 "2023-11-12T13:11:20Z")

</div>

Doing another rebuild now got similar errors:

137:M 12 Nov 2023 13:09:14.143 # Warning: Could not create server TCP listening socket \*:6379: bind: Address already in use  
137:M 12 Nov 2023 13:09:14.143 # Failed listening on port 6379 (TCP), aborting.

However is still going remember seeing these before but install still completed.

Are you logged in to the server console with ssh as root?

A couple times in the install takes awhile to complete seemed like over 10 minutes, had thought this was crashing at first but after waiting for enough time it completed.

Lot of errors about incorrect/unmet peer dependency.

Then it stops after the line “background saving terminated with success,” which sounds like a conclusion but apparently not this is where it can take ten minutes to move on to the next step.

---

<div class="post-metadata">

### Author: ![lubezniy](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/lubezniy/32/137694_2.png) [@lubezniy](https://meta.discourse.org/u/lubezniy)
#### Post date: [November 12, 2023, 1:59pm UTC](https://meta.discourse.org/t/update/285222/8 "2023-11-12T13:59:35Z")

</div>

To view the log details, you can do something like this:

login as root or make “ **sudo su** ”  
then execute commands:

cd /var/discourse  
./launcher enter app  
tail -f log/production.log

After running the last command you need to make HTTP request to your Discourse. A new error message will be displayed in your shell. Then you can stop **tail** command execution using **Ctrl+C** and view or copy message.

To exit container shell, you can use **exit** command.

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 12, 2023, 3:21pm UTC](https://meta.discourse.org/t/update/285222/9 "2023-11-12T15:21:04Z")

</div>

> [@anon65426961](#):
>
> ssh as root

yes

> [@lubezniy](#):
>
> After running the last command you need to make HTTP request

Error response from daemon: Container 0be0150fecde6af5e98c0f12b97d24ccc1333fee2e96f02174ac63b79df8efbc is not running  
tail: cannot open ‘log/production.log’ for reading: No such file or directory  
tail: no files remaining

I tried the HTTP request as curl “[https://forum.full30.com](https://forum.full30.com)"

and got

curl: (3) URL using bad/illegal format or missing URL

so… may be I simply did not understand what you meant by http request 🤷‍♂️

---

<div class="post-metadata">

### Author: ![simon](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/simon/32/339122_2.png) [@simon](https://meta.discourse.org/u/simon)
#### Post date: [November 12, 2023, 8:38pm UTC](https://meta.discourse.org/t/update/285222/10 "2023-11-12T20:38:05Z")

</div>

> [@anon48433008](#):
>
> I see Nov 5th as most recent,

With that being your most recent backup, and me not being an expert in this kind of thing, I’m not sure I should be giving advice here.

As far as I can tell, the issue with `Warning: Could not create server TCP listening socket *:6379` is probably unrelated to the errors you are getting for the migrations. For example:

```plaintext
INFO -- cd /var/www/discourse and su discourse -c 'bundle exec rake db:migrate'

ERROR: database "discourse" already exists

Error: role "discourse" already exists

Error: relation "summary_sections" already exists

```

Those errors seem to suggest that your database is somehow corrupted. The `bundle exec rake db:migrate` command (that’s in the INFO section of the snippet of your logs that I posted above) should trigger Discourse to check the database’s `schema_migrations` table to see what migrations have been previously run. That prevents the same migration from being run multiple times. So my guess is that either your database’s `schema_migrations` table is corrupt, or that duplicate entries have somehow made there way into the `db/migrations` folder, or files in the `db/migrations` folder have somehow been renamed. I’m not sure what could trigger any of these things to happen.

I’d be tempted to enter the app with `./launcher enter app` and run the migration manually from there to see if that makes any difference. Hold off on doing that though. Hopefully someone with more knowledge of the launcher scripts will see this post and correct anything I’ve written that’s wrong.

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 12, 2023, 9:08pm UTC](https://meta.discourse.org/t/update/285222/11 "2023-11-12T21:08:56Z")

</div>

Curious on your opinion, or anyone’s

We’re planning another server move, would this be a good time as these problems seem to be centered around

`PG::DuplicateTable: ERROR: relation "summary_sections" already exists`

etc already exists items?

Might a move help?

---

<div class="post-metadata">

### Author: ![simon](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/simon/32/339122_2.png) [@simon](https://meta.discourse.org/u/simon)
#### Post date: [November 12, 2023, 9:14pm UTC](https://meta.discourse.org/t/update/285222/12 "2023-11-12T21:14:36Z")

</div>

> [@anon48433008](#):
>
> Might a move help?

I suspect that would solve the issue. It couldn’t hurt to try creating a new installation and importing your most recent backup file into it.

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 12, 2023, 9:49pm UTC](https://meta.discourse.org/t/update/285222/13 "2023-11-12T21:49:06Z")

</div>

> [@simon](#):
>
> creating a new installation

The site already seems to think it is a new installation, note some of my screencaps

That occurred simply when I used safemode , its a pretty substantial crash just from an update, and the more odd if just my instance of discourse affectedly just toppled

I’ve done git pulls etc no different I’d say form building new, if I’m wrong please tell me how

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 12, 2023, 10:35pm UTC](https://meta.discourse.org/t/update/285222/14 "2023-11-12T22:35:47Z")

</div>

tried

`./launcher start-cmd app`

`./launcher cleanup`

deleted 18mb of images , did a new pull/rebuild/fail/doctor and still no joy

all my info is still present when I access my APP so there’s that at least

---

<div class="post-metadata">

### Author: ![Firepup650](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/firepup650/32/465200_2.png) [@Firepup650](https://meta.discourse.org/u/Firepup650)
#### Post date: [November 13, 2023, 2:05pm UTC](https://meta.discourse.org/t/update/285222/15 "2023-11-13T14:05:19Z")

</div>

I’m 95% sure that the duplicate table errors are actually safe to ignore. (I remember seeing them every upgrade on our forum)

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 13, 2023, 3:11pm UTC](https://meta.discourse.org/t/update/285222/16 "2023-11-13T15:11:00Z")

</div>

> [@Firepup650](#):
>
> safe to ignore

I ignored them but am still unable to get back online,

> [@anon65426961](#):
>
> Lot of errors about incorrect/unmet peer dependency.

what do you think of those errors?

---

<div class="post-metadata">

### Author: ![Firepup650](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/firepup650/32/465200_2.png) [@Firepup650](https://meta.discourse.org/u/Firepup650)
#### Post date: [November 13, 2023, 3:53pm UTC](https://meta.discourse.org/t/update/285222/17 "2023-11-13T15:53:08Z")

</div>

Could you post a full log from a rebuild?

---

<div class="post-metadata">

### Author: ![deoxyseia](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/deoxyseia/32/201061_2.png) [@deoxyseia](https://meta.discourse.org/u/deoxyseia)
#### Post date: [November 13, 2023, 4:10pm UTC](https://meta.discourse.org/t/update/285222/18 "2023-11-13T16:10:50Z")

</div>

I had yesterday the same problem. I thought is was a server problem because in previous updates had similar behaviour, and decided to run to solve temporarily

> /launcher rebuild app

Downloaded the latest backup and deploy a new server. Restores the backup was too easy and mysteriously all is aready updated.

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 13, 2023, 6:26pm UTC](https://meta.discourse.org/t/update/285222/19 "2023-11-13T18:26:33Z")

</div>

> [@deoxyseia](#):
>
> /launcher rebuild app

```plaintext
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 645 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.2.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
bootstrap failed with exit code 1
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
adb2c505fd2f1289f44586496fea24ff31264f73c26eb524baf16602a189f
root@ip-10-0-159-37:/var/discourse#

```

> [@deoxyseia](#):
>
> deploy a new server.

meaning do what exactly?

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [November 13, 2023, 6:36pm UTC](https://meta.discourse.org/t/update/285222/20 "2023-11-13T18:36:23Z")

</div>

> [@Firepup650](#):
>
> Could you post a full log from a rebuild?

Yes, what should I look to redact first?

[Next page](https://meta.discourse.org/t/update/285222.md?page=2)
