Updating some Gems to latest


(Steve Wills) #1

Continuing the discussion from Gemfile.lock vs Gemfile:

Aside from sprockets-rails and sass, there are other gems that are not the latest. A lot of them probably easily could be.

Here’s a list of the ones that look to me like they could be upgraded without issue:

active_model_serializers
airbrake
ember-rails
ember-source
fspath
handlebars-source
image_optim
image_size
in_threads
message_bus
oj
omniauth-facebook
onebox
progress
onebox
ruby-readability
rack-openid

There are some others that are out of date but from looking at the history are held back for specific reasons:

pg
sprockets-rails
sass
libv8

And a few others that are old simply because other gems depend on the older version, such as exifr and celluloid.

Still, the ones in the first list are probably fine. Would you be willing to try newer versions?

Thanks!


(Steve Wills) #2

Ok, sorry, forget part of what I said there, some of those like image_optim (and it’s deps) are held back on purpose, others are fairly large version jumps, etc.

But I did test upgrading these:

fspath
message_bus
oj
omniauth-facebook
ruby-readability
rack-mini-profiler

And everything seems fine.


(Sam Saffron) #3

This is sounding really weird … both are on latest.


(Steve Wills) #4

Oh, sorry, I am using 1.0.3… I suppose if I’m looking at latest gems I should be using master, eh? Sorry…