Upgrade "currently upgrading" forever


(Jay Pfaffman) #1

At some point an upgrade via the web interface failed. (I think it was when I ran out of memory, but I can’t remember. :smile: )

I made the upgrade work last time by doing a ./launcher rebuild app. Today when I went to the admin page, it said that there was an upgrade, but it still reported “upgrade in progress.” I did another ./launcher rebuild app and all’s well as far as the upgrade goes, but it still reports “currently upgrading.”

Is there some way that I can convince it that it has finished upgrading? Should ./launcher rebuild app do something to clear that status?


Discourse stuck on "Currently Upgrading"
Upgrade stalled, followed advice on forum, now forum not accessible
(@SenpaiMass) #2
cd /var/discourse
git pull
./launcher rebuild app

Have you tried git pull before upgrading ?


(Allen - Watchman Monitoring) #3

Just a rebuild won’t solve this… I fixed it here:

Also related:

I think something in the rebuild process needs to be done so that it clears a flag?


(Jeff Atwood) #4

Rebooting the instance is the simplest way, or flush redis. The problem is the prior upgrade terminated due to an out of memory error.

Perhaps we should block web upgrade unless there is 2GB+ RAM, or 1GB RAM with a 2GB swapfile?


(Allen - Watchman Monitoring) #5

I’ve rebuilt countless times and only hit this issue once. I do have 2GB Ram on all my instances.


(Jay Pfaffman) #6

Rebooting does not solve this.

Clicking the “currently upgrading” and “reset upgrade” worked. Not sure why I didn’t try that sooner.

Hopefully now that I have 2GB of swap I won’t have any more problems.


(Allen - Watchman Monitoring) #7

I didn’t try it sooner bc the reset button is behind a “please wait” button, which is stuck … so why would I push it?

I don’t know why a rebuild can’t/doesn’t clear the upgrading flag, but I wish it would.