Upgrade discourse on docker fails but not really?


(Dave McClure) #1

We have discourse installed via the normal docker install. HTTPS is not (yet?) configured.

Whenever I do an update, it appears to succeed in most senses (I can see I’m on the latest commit, and new features and fixes are working as far as I can tell).

But two things complain:

First, during the upgrade itself, I get this in the log, saying it failed:

********************************************************
*** Please be patient, next steps might take a while ***
********************************************************
$ bundle install --deployment --without test --without development
Fetching source index from https://rubygems.org/
Could not verify the SSL certificate for
https://d2chzxaqi4y7f8.cloudfront.net/quick/Marshal.4.8/actionmailer-4.1.1.gemspec.rz.
There is a chance you are experiencing a man-in-the-middle attack, but most
likely your system doesn't have the CA certificates needed for verification. For
information about OpenSSL certificates, see bit.ly/ruby-ssl. To connect without
using SSL, edit your Gemfile sources and change 'https' to 'http'.

Second, after the upgrade, it still says I’m on 0.9.9.3 in the dashboard tab of the admin panel:

yet on admin/docker, I’m up to date:

Anyone seen this before? Is there any real problem here? Recommended steps to make things (appear) happier?


(joeygufreda) #2

I had the same issue, and fixed it using this method.

First this:

Then this:

My site was up after those two methods consecutively, FWIW. Make sure you have a good backup before you follow any of my advice, please.


(Dave McClure) #3

OK, all looks good again after doing the above. Thanks!


(joeygufreda) #4

No problem at all. I’m looking to enable HTTPS soon as well, and thought that was the issue for a while. If you are able to get it going, please let me know. I haven’t been able to get very far using the official directions.


(Jeff Atwood) #5

Yeah all you need is

cd /var/docker
git pull
./launcher rebuild app