Upgrade error on AWS free tier t2.micro

unsupported-install

(Timothy Vail) #1

I just tried to update today to the new discourse version and got an error. I updated the docker first, then the discourse, and then the discourse failed to complete. I went to SSH and did git pull and a rebuild, and got an error, now I can’t rebuild my forum. Please help with this.


Unable to restore from backup
Strange error during bootstrap (db:migrate) on Mac
Error after restarting the discourse
(Rafael dos Santos Silva) #2

Please provide the full log. The error is probably higher on the log.


(Tobias Eigen) #3

did you check disk space?

did you try again?


(Jay Pfaffman) #4

If you have the discourse narrative bot plugin installed, you need to remove it.


(Timothy Vail) #5

How do I check disk space? I’m running it on a AWS instance.


(Timothy Vail) #6

I don’t have the narrative bot installed, but I do have the solved plugin installed, should I remove it?


(Jay Pfaffman) #7

Probably not.

Provide the full log as requested above.


(Timothy Vail) #8

I, [2017-06-01T20:20:29.874531 #13] INFO – : > cd /var/www/discourse && su dis course -c 'bundle exec rake db:migrate’
rake aborted!
Aws::Errors::MissingCredentialsError: unable to sign request without credentials set
/var/www/discourse/vendor/bundle/ruby/2.

That is the only error I found in the log, it won’t let me copy the entire thing


Launcher rebuild fails if s3 settings aren't correct
(Jay Pfaffman) #9

That’s not the full log, but perhaps MissingCredentialsError has to do with let’s encrypt. Did you enabled it? Does your host name resolve to your IP?


(Timothy Vail) #10

log.pdf (450.0 KB)

Here is my error log.

What is let’s encrypt?


(Jay Pfaffman) #11

Well, if you don’t remember enabling let’s encrypt to enable https on your site, then that’s probably not the problem.

Your log has lines like this:

HTTP 429 Too Many Requests https://index.rubygems.org/

which suggests that rubygems isn’t letting you download the stuff you need.

There was an earlier thread about rubygems rate limits. That problem was on Linode; this one is AWS. @mpalmer, you might want to take a look.


(Timothy Vail) #13

log.pdf (450.0 KB)
Can you take a look at the log then Rafael?


(Timothy Vail) #14

How do I get rubygems to let me download then? I need to solve this quickly, I have a business I run through the forum.


(Sam Saffron) #15

where is this installed, your IP is being throttled by rubygems now. not much we can do.


(Timothy Vail) #16

It’s installed on Amazon AWS. What is throttled, do you mean they are limiting my access?


(Sam Saffron) #17

It probably means someone in your IP address neighborhood is slamming rubygems with requests, just guessing


(Timothy Vail) #18

Okay, then if I wait a bit it might be okay to rebuild app?


(Matt Palmer) #19

Perhaps. Perhaps not. It all depends on why rubygems is rate-limiting you, exactly. That’s not something we can help figure out, it’s between you, your hosting provider (AWS), and rubygems.org.


(Timothy Vail) #20

I couldn’t find anything by searching about this problem, and it always shows the HTTP 429 too many requests for the same items, and ends exactly at the discoursebot installation part. I tried using an elastic IP address and it was the same. Is there a way to manually download another way from rubygems? Then upload via ftp or something?


(Matt Palmer) #21

You couldn’t find RubyGems.org API - RubyGems Guides ?