# Upgrade Error - rake db:migrate index on theme\_field\_id

**URL:** https://meta.discourse.org/t/upgrade-error-rake-db-migrate-index-on-theme-field-id/278935
**Category:** Self-hosting
**Tags:** two-container, ai
**Created:** [September 13, 2023, 9:05pm UTC](https://meta.discourse.org/t/upgrade-error-rake-db-migrate-index-on-theme-field-id/278935 "2023-09-13T21:05:56Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![Joshua\_Lyon](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/joshua_lyon/32/117236_2.png) [@Joshua\_Lyon](https://meta.discourse.org/u/Joshua_Lyon)
#### Post date: [September 13, 2023, 9:33pm UTC](https://meta.discourse.org/t/upgrade-error-rake-db-migrate-index-on-theme-field-id/278935/3 "2023-09-13T21:33:43Z")

</div>

> [@JammyDodger](#):
>
> For the duplicate index errors, I think if you can `restart web_only` and deal with them from the UI it’s much simpler than doing it in the database. Though I don’t think I’ve seen one on `theme_field_id` before.

Can you clarify what resource it’s referring to as having a duplicate ID? I wasn’t sure exactly what `theme_field_id` refers to.

For the record, I hadn’t shut down the `web_only` container. I usually bootstrap the container first to minimize the outage window:

> [@Faster rebuilds?](https://meta.discourse.org/t/faster-rebuilds/40341/13):
>
> ```plaintext
> ./launcher bootstrap web_only
> 
> ```
> 
> Start outage
> 
> ```plaintext
> ./launcher destroy web_only
> ./launcher start web_only
> 
> ```
> 
> End outage

–

> [@JammyDodger](#):
>
> mentions `discourse-voting` now being `discourse-topic-voting`. You could try and update the link in the plugin section to the current one and see if that helps?

I’ll give it a try. I suspect it won’t help as I would think GitHub is redirecting things silently behind the scenes and it’s just a warning on the Discourse side. 🙂

---

_[View the full topic](https://meta.discourse.org/t/upgrade-error-rake-db-migrate-index-on-theme-field-id/278935)._
