# Upgrade failed admin console

**URL:** https://meta.discourse.org/t/upgrade-failed-admin-console/210282
**Category:** Self-hosting
**Created:** [November 27, 2021, 3:15pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282 "2021-11-27T15:15:30Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![kdmilelr45](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kdmilelr45/32/220143_2.png) [@kdmilelr45](https://meta.discourse.org/u/kdmilelr45)
#### Post date: [November 27, 2021, 3:15pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/1 "2021-11-27T15:15:30Z")

</div>

when I used the admin console I got this message before it was working fine.  
Upgrades via the web UI are disabled until you run the latest image.

To do so log in to your server using SSH and run:

```
    cd /var/discourse
    git pull
    ./launcher rebuild app

```

and when I followed the simple instructions I got this error message

## FAILED

Pups::ExecError: cd /var/www/discourse && su discourse -c ‘bundle exec rake them es:update assets:precompile’ failed with return #\<Process::Status: pid 518 exit 1\>  
Location of failure: /pups/lib/pups/exec\_command.rb:112:in `spawn’  
exec failed with the params {“cd”=\>“$home”, “hook”=\>“assets\_precompile”, “cmd”=\> [“su discourse -c ‘bundle exec rake themes:update assets:precompile’”]}  
e3eb2969bd230aeaf5a9405901e7059aa898c61b41eec2156960a6bd2e08dd33  
\*\* FAILED TO BOOTSTRAP \*\* please scroll up and look for earlier error messages, there may be more than one.  
./discourse-doctor may help diagnose the problem.

when I perform the ./discourse-doctor it starts rebuilding and I still have the same issue with the admin upgrade console

---

<div class="post-metadata">

### Author: ![IAmGav](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/iamgav/32/235598_2.png) [@IAmGav](https://meta.discourse.org/u/IAmGav)
#### Post date: [November 27, 2021, 3:59pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/2 "2021-11-27T15:59:10Z")

</div>

The error is higher up in the log.

Can you check or post the log file

---

<div class="post-metadata">

### Author: ![kdmilelr45](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kdmilelr45/32/220143_2.png) [@kdmilelr45](https://meta.discourse.org/u/kdmilelr45)
#### Post date: [November 27, 2021, 4:46pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/3 "2021-11-27T16:46:42Z")

</div>

Not sure how far up to go, here is some more

Error response from daemon: driver failed programming external connectivity on endpoint app (1e145a00615964e521bbfcec584bb3adf14171590767841a1eaa58e04b064615): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use  
Error: failed to start containers: app  
Failed to restart the container.

---

<div class="post-metadata">

### Author: ![kdmilelr45](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kdmilelr45/32/220143_2.png) [@kdmilelr45](https://meta.discourse.org/u/kdmilelr45)
#### Post date: [November 27, 2021, 5:01pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/4 "2021-11-27T17:01:26Z")

</div>

Here is the log file attached  
[discourse-debug.txt](https://meta.discourse.org/uploads/short-url/evzaJVzhKBp21BNpVQae2qVWcuc.txt) (167.5 KB)

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [November 27, 2021, 5:57pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/5 "2021-11-27T17:57:18Z")

</div>

> [@kdmilelr45](#):
>
> Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

That looks like you have some other web server running. You can check to see if something has a port open and or see if apache or nginx is running.

> [@kdmilelr45](#):
>
> Location of failure: /pups/lib/pups/exec\_command.rb:112:in `spawn’  
> exec failed with the params {“cd”=\>“$home”, “hook”=\>“assets\_precompile”, “cmd”=\> [“su discourse -c ‘bundle exec rake themes:update assets:precompile’”]}

That looks like you have a theme that has an error. You might do a

```
 ./launcher start app

```

To restart the server (which won’t work if something else is on port 443) and see about removing themes and then adding them back after the upgrade.

---

<div class="post-metadata">

### Author: ![kdmilelr45](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kdmilelr45/32/220143_2.png) [@kdmilelr45](https://meta.discourse.org/u/kdmilelr45)
#### Post date: [November 27, 2021, 7:10pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/6 "2021-11-27T19:10:56Z")

</div>

these are the only two protocols looking at port 443

root@geeksove:/var/discourse# sudo lsof -i:443  
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME  
docker-pr 44758 root 4u IPv4 926438 0t0 TCP \*:https (LISTEN)  
docker-pr 44764 root 4u IPv6 926445 0t0 TCP \*:https (LISTEN)  
root@geeksove:/var/discourse#

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [November 27, 2021, 8:07pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/7 "2021-11-27T20:07:54Z")

</div>

Then what does this say

```
    docker ps

```

---

<div class="post-metadata">

### Author: ![kdmilelr45](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kdmilelr45/32/220143_2.png) [@kdmilelr45](https://meta.discourse.org/u/kdmilelr45)
#### Post date: [November 27, 2021, 8:55pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/8 "2021-11-27T20:55:43Z")

</div>

> [@pfaffman](#):
>
> `docker ps`

root@geeksove:/var/discourse# docker ps  
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES  
8bf07ae47872 local\_discourse/app “/sbin/boot” 7 weeks ago Up 2 hours 0.0.0.0:80-\>80/tcp, :::80-\>80/tcp, 0.0.0.0:443-\>443/tcp, :::443-\>443/tcp app

Thank you for the help

Keith

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [November 27, 2021, 9:53pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/9 "2021-11-27T21:53:40Z")

</div>

So discourse is already running.

---

<div class="post-metadata">

### Author: ![kdmilelr45](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kdmilelr45/32/220143_2.png) [@kdmilelr45](https://meta.discourse.org/u/kdmilelr45)
#### Post date: [November 27, 2021, 10:28pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/10 "2021-11-27T22:28:09Z")

</div>

Yes, and works except the upgrade module, it keep going to the original message–

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [November 27, 2021, 10:42pm UTC](https://meta.discourse.org/t/upgrade-failed-admin-console/210282/11 "2021-11-27T22:42:43Z")

</div>

I think that you have a theme component that is the issue. You need to remove it, upgrade, and then add back the themes until you find the problem. Or, so I think.
