# Upgrade failed, "FAILED TO BOOTSTRAP", error 137

**URL:** https://meta.discourse.org/t/upgrade-failed-failed-to-bootstrap-error-137/241717
**Category:** Self-hosting
**Tags:** server-resources
**Created:** [October 12, 2022, 5:47pm UTC](https://meta.discourse.org/t/upgrade-failed-failed-to-bootstrap-error-137/241717 "2022-10-12T17:47:11Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [October 12, 2022, 5:59pm UTC](https://meta.discourse.org/t/upgrade-failed-failed-to-bootstrap-error-137/241717/2 "2022-10-12T17:59:38Z")

</div>

I think error 137 is not enough memory. Did you do a [standard install](https://meta.discourse.org/t/142537?silent=true) and let it add some swap when it gave you the option?

There’s a pretty informative discussion about a similar error in this topic, if it sounds like it could be the case:

> [@Failed to upgrade discourse instance to Feb 15 2022](https://meta.discourse.org/t/failed-to-upgrade-discourse-instance-to-feb-15-2022/218204):
>
> Upgrading from [Commits · discourse/discourse · GitHub](https://github.com/discourse/discourse/commits/55007fbf5597e8d6c52464b93f519794bd9fb516) to the latest has caused the site to go down, here is notable segments of the logs: I, [2022-02-15T05:27:48.995821 #1] INFO -- : Replacing (?-mix:^host.\*all.\*all.\*127.\*$) with host all all 0.0.0.0/0 md5 in /etc/postgresql/13/main/pg\_hba.conf I, [2022-02-15T05:27:48.997476 #1] INFO -- : Replacing (?-mix:^host.\*all.\*all.\*::1\/128.\*$) with host all all ::/0 md5 in /etc/postgresql/13/main/pg\_hba.conf I, [2022-02-15T05:27:48.998553 #1] INFO --…

---

_[View the full topic](https://meta.discourse.org/t/upgrade-failed-failed-to-bootstrap-error-137/241717)._
