# Upgrade failing with FAILED TO BOOTSTRAP

**URL:** https://meta.discourse.org/t/upgrade-failing-with-failed-to-bootstrap/218723
**Category:** Self-hosting
**Created:** [February 18, 2022, 7:49pm UTC](https://meta.discourse.org/t/upgrade-failing-with-failed-to-bootstrap/218723 "2022-02-18T19:49:10Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![burke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/burke/32/4211_2.png) [@burke](https://meta.discourse.org/u/burke)
#### Post date: [February 18, 2022, 8:09pm UTC](https://meta.discourse.org/t/upgrade-failing-with-failed-to-bootstrap/218723/3 "2022-02-18T20:09:40Z")

</div>

Ah. I see. We’re running [discourse\_docker](https://github.com/discourse/discourse_docker/) with [linked web and data containers](https://meta.discourse.org/t/linking-containers-for-a-multiple-container-setup/20867), so Redis is running within our data container.

Within our data container:

```plaintext
# redis-server --version
Redis server v=5.0.5

```

So, that explains it. It looks like we need to upgrade our data container as well. That makes me more nervous. When was that requirement added? Maybe I could revert to a previous version of the web container until my reinforcements (in Australia) are awake & available. 😉

---

_[View the full topic](https://meta.discourse.org/t/upgrade-failing-with-failed-to-bootstrap/218723)._
