# Upgrade failing with FAILED TO BOOTSTRAP

**URL:** https://meta.discourse.org/t/upgrade-failing-with-failed-to-bootstrap/218723
**Category:** Self-hosting
**Created:** [February 18, 2022, 7:49pm UTC](https://meta.discourse.org/t/upgrade-failing-with-failed-to-bootstrap/218723 "2022-02-18T19:49:10Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![burke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/burke/32/4211_2.png) [@burke](https://meta.discourse.org/u/burke)
#### Post date: [February 18, 2022, 8:14pm UTC](https://meta.discourse.org/t/upgrade-failing-with-failed-to-bootstrap/218723/4 "2022-02-18T20:14:18Z")

</div>

Wow. Looking through [git history](https://github.com/discourse/discourse_docker/blame/776a4f3a66535407132ede6a5244e430888727f4/image/base/install-redis#L5) it looks like the Redis version hasn’t been in 5.x range for two years! But I know we’ve done some successful upgrades along the way (including git pulls).

Based on [Skip Redis Version Check](https://meta.discourse.org/t/skip-redis-version-check/218480/), it looks like they recently started getting enforced. I’ve already dug a big enough hole for a Friday and don’t want to try upgrading our data container without some help… so, I’ll try reverting to an even earlier version of docker\_discourse to see if I can get to back to a state where the Redis requirement isn’t enforced for now (until we can get our data container updated).

---

_[View the full topic](https://meta.discourse.org/t/upgrade-failing-with-failed-to-bootstrap/218723)._
