# Upgrade from Admin: Operation not permitted

**URL:** <https://meta.discourse.org/t/upgrade-from-admin-operation-not-permitted/30695>\
**Category:** Support\
**Tags:** docker\
**Created:** [02.Июль.2015 05:33:51 UTC](https://meta.discourse.org/t/upgrade-from-admin-operation-not-permitted/30695 "2015-07-02T05:33:51Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![hongquan](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/hongquan/32/115859_2.png) [@hongquan](https://meta.discourse.org/u/hongquan)\
**Post date:** [02.Июль.2015 05:33:51 UTC](https://meta.discourse.org/t/upgrade-from-admin-operation-not-permitted/30695/1 "2015-07-02T05:33:51Z")

</div>

I tried to upgrade Discourse from Admin UI, but failed due to “Operation not permitted” error

```plaintext
$ cd /var/www/discourse && git fetch && git reset --hard HEAD@{upstream}
warning: unable to unlink app/assets/javascripts/admin/models/report.js: Operation not permitted
warning: unable to unlink app/assets/javascripts/discourse/templates/search/category_result.hbs: Operation not permitted
warning: unable to unlink app/assets/javascripts/discourse/templates/search/post_result.hbs: Operation not permitted

```

Tried looking for similar topic in this forum, but not found. So I have to create this topic. Here is the Linux account detail:

- The docker software is installed with `sudo apt-get`, by _kaka\_root_ user. This user is normal user, but is “sudoer”.
- The git repo _discourse\_docker_ is cloned by _kaka\_dev_ user. This user is not “sudoer”. This user can run `./launcher ssh app` successfully, and become _root_ inside container after that. This user can also run `./launcher rebuild app` successfully.
- Inside container, the folder _/var/www/discourse/_ is under _discourse_ user.

Platform detail:  
Linux hostname 3.5.0-52-generic #79~precise1-Ubuntu SMP Fri Jul 4 21:03:49 UTC 2014 x86\_64 x86\_64 x86\_64 GNU/Linux

I can upgrade Discourse successfully with `./launcher` command. But my team want to be able to do in Admin UI.

How can I solve this?  
Thanks and regards.

---

<div class="post-metadata">

**Author:** ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)\
**Post date:** [07.Июль.2015 07:03:34 UTC](https://meta.discourse.org/t/upgrade-from-admin-operation-not-permitted/30695/2 "2015-07-07T07:03:34Z")

</div>

> [@hongquan](#):
>
> But my team want to be able to do in Admin UI.

Some older versions require a rebuild, once that is done it should be fine going forward.

---

<div class="post-metadata">

**Author:** ![hongquan](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/hongquan/32/115859_2.png) [@hongquan](https://meta.discourse.org/u/hongquan)\
**Post date:** [07.Июль.2015 11:54:58 UTC](https://meta.discourse.org/t/upgrade-from-admin-operation-not-permitted/30695/3 "2015-07-07T11:54:58Z")

</div>

I rebuilt by command line. After some days, Discourse had new update, tried from Admin but failed, had to rebuild by command line. After that, Discourse had new update again, tried to upgrade from Admin again and still not work.

— Update —  
Just noticed that our server is using kernel v3.5, far older than Docker requirement, v3.10. This may be the cause of the problem.

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [15.Декабрь.2015 12:00:59 UTC](https://meta.discourse.org/t/upgrade-from-admin-operation-not-permitted/30695/4 "2015-12-15T12:00:59Z")

</div>


