Upgrade from an ancient version


(zh99998) #1

I’m upgrading an ancient discourse forum, seems it’s version 0.6.1, not installed with docker.

I’m trying to just setup a latest discourse forum, then replace with old database, and run db:migrate, but seems migrate script is broken too.


(zh99998) #2

I copied a translation_overrides table from latest version, it works.

but this is still a bug…
if this table change again, maybe there is no way to upgrade…


(Jeff Atwood) #3

I don’t know if upgrading from a version that old is even possible. That’s like Feb 2013 old.


(Sam Saffron) #4

Our migrations should run fine from any point, this particular case looks like someone is reaching to translate stuff during migration which really should be avoided and left in seeds.


(Robin Ward) #5

This is my fault. The site text feature didn’t exist when that migration happened so it needed to disable the feature in order to work: