# PostgreSQL 13에서 15로 업그레이드 실패 - 현재 포럼 사용 불가

**URL:** https://meta.discourse.org/t/upgrade-from-postgres-13-to-15-failing-currently-means-forum-is-unavailable/357028
**Category:** Support
**Tags:** postgres
**Created:** [3월 12, 2025, 8:56오후 UTC](https://meta.discourse.org/t/upgrade-from-postgres-13-to-15-failing-currently-means-forum-is-unavailable/357028 "2025-03-12T20:56:59Z")
**Posts on this page:** 1
**Showing post:** 9

<div class="post-metadata">

### Author: ![mwaniki](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mwaniki/32/313097_2.png) [@mwaniki](https://meta.discourse.org/u/mwaniki)
#### Post date: [3월 13, 2025, 11:00오전 UTC](https://meta.discourse.org/t/upgrade-from-postgres-13-to-15-failing-currently-means-forum-is-unavailable/357028/9 "2025-03-13T11:00:33Z")

</div>

> [@tanya\_byrne](#):
>
> 이제 백업에서 복구하고 있습니다

사이트를 성공적으로 복구할 수 있었나요?

> [@Heliosurge](#):
>
> Ubuntu LTS를 사용 중이라면 서버 버전이 얼마인가요?

정말 오래된 OS와 Docker 버전을 사용하고 있다면, 재빌드를 다시 시도하기 _전에_ 둘 다 업데이트하는 것을 권장합니다.

> [@tanya\_byrne](#):
>
> 스크립트가 그냥 멈춰버립니다

아마도 [대형 데이터베이스](https://meta.discourse.org/t/postgresql-stuck-during-rebuilding/323434/38)를 업데이트 중이셨을 수 있습니다. 그렇다면 업데이트가 아직 실행 중일 수 있습니다. 재빌드 중에는 `postgres_data`와 `postgres_data_new` 디렉터리의 크기를 주기적으로 비교해 볼 수 있습니다. `postgres_data_new`의 크기가 계속 증가하고 있다면 업데이트가 아직 진행 중이라는 뜻입니다. (프로세스 목록에서 `pg_upgrade` 명령어가 실행 중인지도 확인할 수 있습니다.)

* * *

> [@tanya\_byrne](#):
>
> ```plaintext
> cp: cannot stat '/etc/postgresql/13/main/*': No such file or directory
> 
> ```

그 `cp` 오류는 당분간 무시하셔도 됩니다. 동일한 오류가 발생했지만 표준 설치 환경의 테스트 사이트는 업데이트에 성공했습니다. (이것은 [상류(upstream) 변경 사항](https://salsa.debian.org/postgresql/postgresql-common/-/commit/d9139f7777a42a39b5b6fabbffc9f020fad4dce5)으로 인해 발생한 것이므로 이미지를 수정하여 오류를 제거할 예정이지만, 이전에 postgres 설정이 크게 수정되지 않았다면 데이터베이스 업데이트에 영향을 주지 않아야 합니다.)

---

_[View the full topic](https://meta.discourse.org/t/upgrade-from-postgres-13-to-15-failing-currently-means-forum-is-unavailable/357028)._
