Upgrade from v1.7.0.beta2

(Federico) #1

I have version v1.7.0.beta2, and I tried to upgrade it but it doesn’t work.
How can I upgrade it?

Or at least, upgrade to a specific commit, so I go step by step.
Is that possible?

(cpradio) #2

Can you define “doesn’t work”?

What error are you getting? What issue are you running into?

(Federico) #3

It says it can’t remove postgres 9.5 and some dependencies.
After that, I can’t even restart the app, so I can’t use admin.

(cpradio) #4

Ah, you will probably want to read this then

(Federico) #5
root@ip-172-30-0-241:/var/discourse# ./launcher rebuild app
Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 10 app
cd /pups && git pull && /pups/bin/pups --stdin
Already up-to-date.
I, [2017-06-09T15:41:19.421365 #13]  INFO -- : Loading --stdin
I, [2017-06-09T15:41:19.425902 #13]  INFO -- : > apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "es_ES.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
E: Sub-process /usr/bin/dpkg returned an error code (1)
I, [2017-06-09T15:41:21.951351 #13]  INFO -- : Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be REMOVED:
  postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
After this operation, 26.1 MB disk space will be freed.
(Reading database ... 34469 files and directories currently installed.)
Removing postgresql-contrib-9.5 (9.5.7-1.pgdg16.04+1) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/share/postgresql/9.5/man/man1/postmaster.1.gz because link group postmaster.1.gz is broken
update-alternatives: error: error creating symbolic link '/usr/share/man/man1/postmaster.1.gz.dpkg-tmp': No such file or directory
dpkg: error processing package postgresql-contrib-9.5 (--remove):
 subprocess installed pre-removal script returned error exit status 2
dpkg: postgresql-9.5: dependency problems, but removing anyway as you requested:
 postgresql-contrib-9.5 depends on postgresql-9.5 (= 9.5.7-1.pgdg16.04+1).

Removing postgresql-9.5 (9.5.7-1.pgdg16.04+1) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of stop.
Removing postgresql-client-9.5 (9.5.7-1.pgdg16.04+1) ...
Processing triggers for postgresql-common (182.pgdg16.04+1) ...
Building PostgreSQL dictionaries from installed myspell/hunspell packages...
Removing obsolete dictionary files:
Errors were encountered while processing:

Pups::ExecError: apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5 failed with return #<Process::Status: pid 15 exit 100>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params "apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5"
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

(Federico) #6

I followed instructions here

(Rafael dos Santos Silva) #7

Did you try:

(Federico) #8

I’m trying everything.
I had upgraded and when I try to restore my backup, I get this error.

Bundled gems are installed into ./vendor/bundle.

I, [2017-06-16T14:01:09.968006 #13]  INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate'
2017-06-16 14:01:15.455 UTC [13337] discourse@discourse ERROR:  permission denied for sequence site_settings_id_seq
2017-06-16 14:01:15.455 UTC [13337] discourse@discourse STATEMENT:  INSERT INTO "site_settings" ("name", "value", "data_type", "created_at", "updated_at") VALUES ('send_welcome_message', 'f', 5, '2017-06-16 14:01:15.454605', '2017-06-16 14:01:15.454605') RETURNING "id"
rake aborted!