Upgrade issues on my forum

Hi there,

A while ago I created a thread with some issues that I have with the forums.

Someone recommended to me that I should upgrade to a newer version of the software. But when I press the upgrade button I get sent to this page:

https://forums.creativehiveco.com/admin/upgrade

And nothing happens, it’s a blank page.

Looking forward to your reply!

Thanks!

1 Like

Maybe do a rebuild via ssh?

FYI, That link can only be seen by an admin of your forum.

1 Like

I suggest updating from the command line via SSH

cd /var/discourse
./launcher rebuild app
3 Likes

Thanks for you reply!

I tried the method suggested by you but it says that my Docker version is outdated. I tried with the update method I found on Google but nothing happens. So can you please suggest my a method to update Docker in the command line?

I think that’s the reason it didn’t work from the site too, since it can’t turn on Docker

For your site to be running docker will be running.

Who but your server? Do you recall who built it?

Hi Stephen,

I’m Sorin, I’m helping Mei with her website.

I tried to update the discourse with the method that was recommended to us here and got into the Docker error.

Finally I managed to update Docker to a newer version following one of your guides here on the forum. But now it says that it can’t connect to Docker Daemon.

At the moment we are running Ubuntu 16.04 and Docker 17.03.03 and the current Discourse version is: 1.8.0-beta2

Thanks!

1 Like

How was docker installed? How did you update it? AFAIK docker 18 is the minimum supported.