# Upgrade of postgres failed

**URL:** https://meta.discourse.org/t/upgrade-of-postgres-failed/165413
**Category:** Self-hosting
**Created:** [September 25, 2020, 8:16pm UTC](https://meta.discourse.org/t/upgrade-of-postgres-failed/165413 "2020-09-25T20:16:04Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [September 25, 2020, 8:19pm UTC](https://meta.discourse.org/t/upgrade-of-postgres-failed/165413/2 "2020-09-25T20:19:37Z")

</div>

> [@Eduar\_Ramos](#):
>
> `The source cluster was not shut down cleanly.`

> [@Eduar\_Ramos](#):
>
> Please visit [https://meta.discourse.org/t/postgresql-12-update/151236](https://meta.discourse.org/t/postgresql-12-update/151236) for support

Visiting that URL, there is a FAQ entry for it:

> [@PostgreSQL 12 update](https://meta.discourse.org/t/postgresql-12-update/151236/1):
>
> If you get a upgrade failed with the above message, you can try a simpler approach to get it back into a better state.
> 
> Restart the old container with `./launcher start app` . Wait a few minutes until it is back up.
> 
> Now shut it down again with `./launcher stop app` . After that tail the logs to see if it was a clean one:
> 
> ```plaintext
> tail -f shared/data/log/var-log/postgres/current
> 2020-05-13 18:33:33.457 UTC [36] LOG: received smart shutdown request
> 2020-05-13 18:33:33.464 UTC [36] LOG: worker process: logical replication launcher (PID 52) exited with exit code 1
> 2020-05-13 18:33:33.465 UTC [47] LOG: shutting down
> 2020-05-13 18:33:33.479 UTC [36] LOG: database system is shut down
> 
> ```
> 
> If the logs look like above, you can now try to upgrade again using `./launcher rebuild app` .

---

_[View the full topic](https://meta.discourse.org/t/upgrade-of-postgres-failed/165413)._
