Upgrade to 2.8.0.beta3 fails

Continuing the discussion from Selectable avatars:

avatar_flair_group_id does not exist

I’m in the process of upgrading to the latest beta, but there seems to be an error that may only affect multi-container, multisite setups, where a missing field breaks the database upgrade, leaving the site(s) unusable.

Previously I had to restore from backup for a multi-container, single site instance, but did not take the time to investigate why. This time the error seems to come from a migration that has not yet run.

Currently running the rebuild on the web_only container after the data container failed to finish the installation. – After rebuilding the web_only container, the site came back to life. Maybe doing the opposite: starting with web_only and ending with the data container, would work better.

1 Like