Upgrade to v1.5.0.beta4 +26 hung


(Jay Pfaffman) #1

I don’t know if this is a bug, and I don’t know how to reproduce it, but don’t know where else to put a heads up that on my digital ocean docker version I clicked the upgrade.

It hung when it was going through the compression stage. When I returned to the dashboard it claimed that it was upgrading (but if it were, I wouldn’t be able to see the dashboard, right?). The warning message on the “Reset upgrade” didn’t make much sense to me and it wasn’t clear what that would do, so here’s what I did instead. (It worked!)

My fix was (as root)

cd /var/discourse/
./launcher rebuild app

Now all seems fine.


(Jeff Atwood) #2

Did you run out of memory? Upgrade time pushes a lot of memory. How much memory and swap do you have? I haven’t seen any update hangs on any of the sites we install on Digital Ocean, following the official install guide, so I don’t consider this a bug.


(Jay Pfaffman) #3

I’ve got a 1GB droplet with 1GB of swap. I followed the official install guide.

Running out of memory seems likely enough. I ran top. CPU was idle, but that might have been after it had given up and crashed.


Problem Replying & Upgrade Problem
(Jeff Atwood) #4

That should work in theory, but you might try 2GB swap. We do 2GB swap on all our installs for safety reasons, maybe that’s why I never see this behavior.


(Jay Pfaffman) #5

Aha! Well, doing the install is a hazy memory, so I don’t know whether the Official Guide says to increase the swap. I upped mine. Maybe that’ll solve my problems. Thanks!

For anyone who doesn’t know, here’s how to increase the swap (on my Digital Ocean install, and probably yours):

sudo swapoff /swapfile
sudo fallocate -l 2G /swapfile
sudo mkswap /swapfile 
swapon -a

Then do a free to make sure you’ve got 2GB of swap. If it didn’t, then check /etc/fstab to see what your swap is.