Upgrading Discourse on Scaleway VPS



Anyone know how to upgrade discourse from this;


Or is it even possible to upgrade it?

How do you update Discourse?
(cpradio) #2

What happens if you visit /admin/upgrade?


@cpradio thanks for reply, this is what happens;

(cpradio) #4

Okay, that doesn’t look like a Docker install unless you already ran ./launcher ssh app, are you using docker?


@cpradio no i’m not on docker, i’m using scaleway VPS. And this is one automatic provided one. So i’m trying to find a way to upgrade it. I was thinking maybe about editing ‘app container’ (That i couldnt find) the config for discourse, and add branch test-passed then > git pull to check if theres updates for it, but that didint worked aswell, since i didint find config proper for it. Thats why i’m searching for assistance ‘I’m lost’ :smile:

(cpradio) #6

Yeah, you are going to have to ask Scaleway VPS, if they went out of the box, there isn’t much we can do here. We have no idea how they set it up…

(cpradio) #7

It does seem like you should be able to do a git pull, but if you tried that and it failed… I’m not sure what else you can do.

Based on this


git pull, works but it says that its already up to date, thats why i was thinking maybe to change some source where git pulls checks it, cause maybe its wrong (Probably it is)… but not sure if that “Pull” would create a mess, or just up/date/grade

(cpradio) #9

oh, it will likely break things. As the gems needed to run discourse likely can’t be installed.

You can see where it is pulling from by running git remote -v



I think its not possbile, to upgrade it to latest one. If anyone have any suggestion or advice that might lead to success, let me know. Thanks :smile:

(cpradio) #12

The thing you’d have to do, and it may break your site is to stop the running rails server, sideqik, etc. Then run bundle install and start them back up if bundle install is successful.

Unfortunately, your server host seems to have left you high and dry with their hackish way to install and run Discourse :frowning:

(Erlend Sogge Heggen) #13

Users of Scaleway should encourage them to jump on the standard Discourse bandwagon. This is their blocker:

Support for ARM servers
(elcore) #14

"At the moment you can’t update discourse with ease on your server as some gems are not natively compatible and we have to do custom stuff to get it running.

I tried to build the latest version (1.4.1) but I encounter an issue that I’m still trying to fix. I ll let you know when the latest version is ready.

The best way to upgrade is to re-deploy a server with the latest version and import your data / db and configuration file on the new server." - Edouard Bonlieu (What is the best approach when updating the Discourse version · Issue #5 · scaleway-community/scaleway-discourse · GitHub)

(Erlend Sogge Heggen) closed #15