Upgrading from v1.5 to v1.6


#1

I’m unable to upgrade my discourse. When I try from the website I get this message.

Upgrades via the web UI are disabled until you run the latest image.

To do so log in to your server using SSH and run:

cd /var/discourse
git pull
./launcher rebuild app

When I try that I get this error message.

ERROR: Docker version 1.2.0 not supported, please upgrade to at least 1.8.0, or recommended 1.8.0


(eriko) #2

You are running a very very old version of docker. It will need to be updated first as the current docker image requires features provided by newer versions of docker.


#3

How do I upgrade the docker?


(Jeff Atwood) #4
apt-get update
apt-get upgrade lxc-docker

That should get you to 1.9 fairly reliably. Do that first. To clean up space, I also recommend

cd /var/discourse
./launcher cleanup
apt-get autoclean
apt-get autoremove

#5

Ok, I went through all these steps but when I finally ./launcher rebuild app my discourse is now completely unresponsive. I get a can’t connect to server error when I try to open from Safari.


(Jeff Atwood) #6

Did you get errors? If you have any non default plugins, remove them.


#7

Thanks for all your help. I’m not using any plugins but I ran the command again and it works now.

The first time I ran the command it ended with this message.

UPGRADE OF POSTGRES COMPLETE

Old 9.3 database is stored at /shared/postgres_data_old

Please run ./launcher bootstrap again

I missed that but the second time I ran ./launcher rebuild app it worked.


(Jeff Atwood) #8

Excellent, good work! You did it! :tada:


(Sam Saffron) #9

Thanks I corrected the text so it is now:

Please run ./launcher rebuild again

(Ionuț Staicu) #10

I already updated few days ago, but if I remember well, this didn’t worked back then either:

$ apt-get upgrade lxc-docker
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
Package lxc-docker is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'lxc-docker' has no installation candidate

I managed to update by removing the old version and reinstall the new one.

$ apt-get purge lxc-docker*
$ curl -fsSL https://get.docker.com/ | sh

Last command took forever to complete. At one point I started to worry, but after ~20 mins it was up & running.

I’m not saying this is the way of upgrading, but this was the way worked for me.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.4 LTS
Release:        14.04
Codename:       trusty