Upgrading hangs forever


(Uwe Keim) #1

Just upgraded this:

Which results in a non-changing progress for now about 15 minutes like this:

The logs under “/logs” contains no information.

Question:

Anything I should do (beside waiting) as the next steps?


(Jeff Atwood) #2

Log in via ssh and upgrade using the 3 line command way!


(Uwe Keim) #3

I’m doing the following now:

cd /var/discourse
git pull
./launcher rebuild app

(Jeff Atwood) #4

It’s a


(Uwe Keim) #5

I’ve done these steps now and even rebooted the server and did the 3 lines again.

Still it is showing:

and

Anything else I can do?

Or simply leave it as it is?


(Jeff Atwood) #6

Weird. Did the upgrade show any errors in the console?

Do you have plugins installed? If you do, can you remove them and try again?


(Uwe Keim) #7

The only plugin i have is the official tagging plugin.

I’ll check the console later when I’m back in the office.


(Uwe Keim) #8

I did again

cd /var/discourse
git pull
./launcher rebuild app

This is the SSH output:

log.txt (215.8 KB)

I do think no severe errors are included, I’ve only found things like these:

I, [2015-05-13T11:44:54.391758 #46]  INFO -- :
I, [2015-05-13T11:44:54.392496 #46]  INFO -- : > su postgres -c 'createdb discourse' || true
2015-05-13 11:44:54 UTC [87-1] postgres@postgres ERROR:  database "discourse" already exists
2015-05-13 11:44:54 UTC [87-2] postgres@postgres STATEMENT:  CREATE DATABASE discourse;

The “/admin/upgrade” page still shows “Currently Upgrading…”.

Anyone has more ideas?


(Sam) #9

The last time I did this I had to hit the ‘reset upgrade’ button to get everything back to normal (SSH upgrade process worked, but docker view didn’t update).

Not sure that this is the recommended approach though, would wait for one of the Discourse folk to respond.


(Uwe Keim) #10

Resetting the upgrade (via the red button on the upper right, see my above screenshots) worked!