Uploaded image gets resized unexpectedly


I tried uploading a 2MB PNG with unusual dimensions (16476 x 3210) to a Discourse forum I use/help administer. The image is a mindmap exported from MindNode. Expected behavior was that a thumbnail would get generated and the full size image would be available for download (as is the case with other large images). The thumbnail got generated, but it appears that the original file gets resized down to 1920 x 374, so that’s the file I get when I try to download it. This 1920x374 file is, of course, illegible due to the loss in resolution.

So my question is: what’s causing this, and is it something I can change as an admin?

I checked to make sure that the max upload size was fine (it is 4Mb, and my file is about half that, so should be good…also I don’t think it’d accept the file if it was over the max anyways?)

As a workaround I uploaded a PDF export of my mind map, which appears to work fine, though I’d prefer to have the option to use images (one reason is that I like having the thumbnail and think it conveys some useful information, whereas with a PDF I just get a text link).


1 Like

I tried disabling composer media image optimization and it seemed to have no effect (got same result as before).

I tried disabling png to jpg conversion by setting png to jpg quality to 100 and got this: