Uploading SVG doesn't work anymore


(Gerhard Schlager) #1

Since this has been changed it’s not possible to upload any SVG images anymore. I can reproduce this here on meta and on my development server.

Steps to reproduce:

Expected behaviour: SVG should be allowed and recognized as image.

Actual behaviour: The following error message appears:

Sorry, but the file you tried to upload doesn’t appear to be an image.

Uploading WEBP works, but it’s not recognized as an image.

BTW: I’m able to upload a SVG and WEBP as avatar, but it’s not visible.


(Vanjacosic) #2

I know it’s not helpful to bump bug reports, but I just wanted to chime in and mention that I’m experiencing the exact same issue.

I want to use SVG files as assets for the site, like logo and other images but can’t because of this issue.

I tried searching in the issue tracker and here and just wanted to see if there was a solution to this? Or if a fix is being worked on? :blush:


(Jeff Atwood) #3

@zogstrip can you have a look at this?


(Régis Hanol) #4

SVGs are now considered as images when authorized :tiger2:

https://github.com/discourse/discourse/commit/bdb78ce76a524f9eb05a0375c1d91c7a8ec3734e


(Régis Hanol) #5

This topic was automatically closed count} hours after the last reply. New replies are no longer allowed.