User can't sign in


(NomNuggetNom ) #1

We have a weird scenario on our instance where one of our users can’t login to the site. When they do, they get a “500 error, Error updating information.” I am able to impersonate the user without an issue, but the user has tried multiple computers/phones/browsers/etc and nothing has worked yet.

We use SSO to override logins, but I don’t think that is the problem. Luckily we did some trial and error and I managed to snag a log of the problem:

TypeError: undefined is not an object (evaluating 'e.get("controller").show(t,n,s[0]).then')
Url: http://forum.minecraftpvp.com/assets/application-b9c1b446bc3b33a4b6ea85ac9b2ce0ab.js
Line: 16
Column: 56780

There is no backtrace. Any clue what’s going on here? Happy to provide any other info needed.


(Jeff Atwood) #2

What’s different about this user? If you create a new user from scratch can you repro failure to log in?


(NomNuggetNom ) #3

Nothing about the user is that different. This is definitely an isolated issue. I don’t think this is the first time it has happened, but this is the first exact and reproducible instance I’ve found.


#4

Could the user’s IP be blocked? It could be hitting this line (unknown_error translates to “error updating information”). Whether it is or not, that line seems to be giving the wrong error message.


(NomNuggetNom ) #5

He can view the forum but can’t sign in. He has also tried from multiple
IPs.


(Robin Ward) #6

Unfortunately that Javascript error is minified so it’s hard for me to debug. I think unfortunately I’ll need a way to reproduce it to fix it for you.


(NomNuggetNom ) #7

Would poking at our instance from the inside offer anything? I’d be happy to let you :). I don’t see us reproducing this any time soon.


(Robin Ward) #8

If you can’t reproduce by impersonating then there isn’t much I can do either :frowning:

Maybe if they gave you their password to try that way and it broke? I could then try the same and look at the error.


(NomNuggetNom ) #9

Alright, I’ll see if he’s willing to send me info. Thanks.