User fields issues (preventing signup)


(James Milligan) #1

I note that this was in a recent commit, so it’s more than likely that this has just not been finished, rather than a bug.

On latest pull from the repo, I added a user field via Customise, a standard text field with “Membership Number” in, and set it to “not editable” after signup.

Going to the signup page shows the usual form (username/password etc), but no box for a field. Trying to register fails, see screenshot below.

The field also doesn’t show on a user’s profile at all, although when set to be editable, is so via preferences.


Inconsistencies on "User Fields" admin interface
(Jeff Atwood) #2

Did you scroll down? There was a giant <h3> there that I severely objected to and removed.


(Robin Ward) #3

Can you confirm that you refreshed your browser after you added the field? I suspect that the window you tried to create the account in was not refreshed.


(James Milligan) #4

Yep definitely refreshed, just tried on mobile.

I’ve got the fix you popped on earlier @jeff but no luck getting it to display the field.


(Robin Ward) #5

Any way you’d let me take a look at the instance? I am out of ideas and it should be working.


(James Milligan) #6

Not at the moment unfortunately, but I’ve replicated it on a local VM running a Docker install. It appears ‘login required’ is the setting that removes the field from the signup page. Toggling it off shows the field, and vice versa.


(Robin Ward) #7

Awesome, that’s all I needed. A fix is coming soon.


(James Milligan) #8

Great, looks like your commit below fixed the issue. Cheers @eviltrout :thumbsup:

https://github.com/discourse/discourse/commit/381814fd5dd45ba0f92a4ffc1c5d6991918af04f


(Jeff Atwood) #9