Usernames with accents disallowed?


#1

So I have a user whose name is René and who, on the old Vanilla Forum, had that same username. Now Discourse does not allow é in usernames since it treats that as a special character. Is this something that could be changed, to allow for special letter variants like ñ or ç or î etc.?


(Rafael dos Santos Silva) #2

In the mean time, you can turn the setting to put more emphasis on the Full Name. Even the username being rene, the first thing to show on posts will be René.


#3

Where do I find that setting? I have Real Names enabled but it stil shows usernames first.


(Rafael dos Santos Silva) #4

prioritize username in ux

You need to disable that.


#5

I’ve disabled that, I still get the user names on posts. Though on the userCard I get the real name first.

Notice tha the name is with space, the username without.


(Jeff Atwood) #6

Full names have complete unicode support.

If you want to hide usernames altogether you’ll need to enter custom CSS in Admin, Customize, HTML/CSS to do that.


(Kane York) #7

If the only difference between the Full Name and the username is the spacing, the opposite name is displayed, I think.


#8

Kane, I know. In this example username and real name are close, but the thing that bothers me is that next to posts I am seeing the USERNAMES, not the REAL NAMEs (see just above the box). This is different from this forum, where I can see the Real name, then the username, then the title.

I have set “prioritize user names” (?) to false but that did not make the change as expect, so I’m wondering what else I need to change.


(Jeff Atwood) #9

What version of Discourse are you on?


#10

According to the Admin panel it’s v1.7.0.beta5 +64