# Users getting Internal Server Error when trying to change email address

**URL:** https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416
**Category:** Bug
**Created:** [February 4, 2025, 11:34am UTC](https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416 "2025-02-04T11:34:20Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Richie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/richie/32/115110_2.png) [@Richie](https://meta.discourse.org/u/Richie)
#### Post date: [February 4, 2025, 11:34am UTC](https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416/1 "2025-02-04T11:34:20Z")

</div>

Discourse 3.4.0.beta4-dev ([5bc7371192](https://github.com/discourse/discourse/commits/5bc73711927005513a151d9d4a42c27d42404055)).

Users are unable to change their email address to a previously used email address.

Steps to replicate:

1. Change your account email address to something with a `+` sign in it, eg. `your+name@example.com`

_(The plus sign may be the significant key here, or it may be a red herring)_

1. Follow the email prompts to confirm the change

2. Change your email address back to what it was previously, eg. `yourname@example.com`

3. Follow the email prompts to confirm the change

4. Error is thrown in the front end:

 ![Screenshot 2025-02-04 at 11.25.30](https://global.discourse-cdn.com/meta/original/4X/1/3/9/1392bfe9232a0e5076d38afdee5acdc40e9f47fd.png)

User is then stuck with:

 ![Screenshot 2025-02-04 at 11.30.34](https://global.discourse-cdn.com/meta/original/4X/6/3/6/6367c6c680e6a7a3aa85784ba4ba51e774ad88b5.png)

* * *

Error from `/logs` page:

```plaintext
lib/email_updater.rb:136:in `update_user_email'

lib/email_updater.rb:126:in `block in confirm'

activerecord (7.2.2.1) lib/active_record/connection_adapters/abstract/transaction.rb:616:in `block in within_new_transaction'

activesupport (7.2.2.1) lib/active_support/concurrency/null_lock.rb:9:in `synchronize'

activerecord (7.2.2.1) lib/active_record/connection_adapters/abstract/transaction.rb:613:in `within_new_transaction'

activerecord (7.2.2.1) lib/active_record/connection_adapters/abstract/database_statements.rb:361:in `transaction'

activerecord (7.2.2.1) lib/active_record/transactions.rb:234:in `block in transaction'

activerecord (7.2.2.1) lib/active_record/connection_adapters/abstract/connection_pool.rb:421:in `with_connection'

activerecord (7.2.2.1) lib/active_record/connection_handling.rb:296:in `with_connection'

activerecord (7.2.2.1) lib/active_record/transactions.rb:233:in `transaction'

lib/email_updater.rb:87:in `confirm'

app/controllers/users_email_controller.rb:64:in `confirm_new_email'

actionpack (7.2.2.1) lib/action_controller/metal/basic_implicit_render.rb:8:in `send_action'

actionpack (7.2.2.1) lib/abstract_controller/base.rb:226:in `process_action'

actionpack (7.2.2.1) lib/action_controller/metal/rendering.rb:193:in `process_action'

actionpack (7.2.2.1) lib/abstract_controller/callbacks.rb:261:in `block in process_action'

activesupport (7.2.2.1) lib/active_support/callbacks.rb:121:in `block in run_callbacks'

app/controllers/application_controller.rb:424:in `block in with_resolved_locale'

i18n (1.14.7) lib/i18n.rb:353:in `with_locale'

app/controllers/application_controller.rb:424:in `with_resolved_locale'

activesupport (7.2.2.1) lib/active_support/callbacks.rb:130:in `block in run_callbacks'

activesupport (7.2.2.1) lib/active_support/callbacks.rb:141:in `run_callbacks'

actionpack (7.2.2.1) lib/abstract_controller/callbacks.rb:260:in `process_action'

actionpack (7.2.2.1) lib/action_controller/metal/rescue.rb:27:in `process_action'

actionpack (7.2.2.1) lib/action_controller/metal/instrumentation.rb:77:in `block in process_action'

activesupport (7.2.2.1) lib/active_support/notifications.rb:210:in `block in instrument'

activesupport (7.2.2.1) lib/active_support/notifications/instrumenter.rb:58:in `instrument'

activesupport (7.2.2.1) lib/active_support/notifications.rb:210:in `instrument'

actionpack (7.2.2.1) lib/action_controller/metal/instrumentation.rb:76:in `process_action'

actionpack (7.2.2.1) lib/action_controller/metal/params_wrapper.rb:259:in `process_action'

activerecord (7.2.2.1) lib/active_record/railties/controller_runtime.rb:39:in `process_action'

actionpack (7.2.2.1) lib/abstract_controller/base.rb:163:in `process'

actionview (7.2.2.1) lib/action_view/rendering.rb:40:in `process'

actionpack (7.2.2.1) lib/action_controller/metal.rb:252:in `dispatch'

actionpack (7.2.2.1) lib/action_controller/metal.rb:335:in `dispatch'

actionpack (7.2.2.1) lib/action_dispatch/routing/route_set.rb:67:in `dispatch'

actionpack (7.2.2.1) lib/action_dispatch/routing/route_set.rb:50:in `serve'

actionpack (7.2.2.1) lib/action_dispatch/journey/router.rb:53:in `block in serve'

actionpack (7.2.2.1) lib/action_dispatch/journey/router.rb:133:in `block in find_routes'

actionpack (7.2.2.1) lib/action_dispatch/journey/router.rb:126:in `each'

actionpack (7.2.2.1) lib/action_dispatch/journey/router.rb:126:in `find_routes'

actionpack (7.2.2.1) lib/action_dispatch/journey/router.rb:34:in `serve'

actionpack (7.2.2.1) lib/action_dispatch/routing/route_set.rb:896:in `call'

lib/middleware/omniauth_bypass_middleware.rb:64:in `call'

rack (2.2.10) lib/rack/tempfile_reaper.rb:15:in `call'

rack (2.2.10) lib/rack/conditional_get.rb:40:in `call'

rack (2.2.10) lib/rack/head.rb:12:in `call'

actionpack (7.2.2.1) lib/action_dispatch/http/permissions_policy.rb:38:in `call'

lib/content_security_policy/middleware.rb:12:in `call'

lib/middleware/anonymous_cache.rb:403:in `call'

lib/middleware/csp_script_nonce_injector.rb:12:in `call'

config/initializers/008-rack-cors.rb:14:in `call'

rack (2.2.10) lib/rack/session/abstract/id.rb:266:in `context'

rack (2.2.10) lib/rack/session/abstract/id.rb:260:in `call'

actionpack (7.2.2.1) lib/action_dispatch/middleware/cookies.rb:704:in `call'

actionpack (7.2.2.1) lib/action_dispatch/middleware/callbacks.rb:31:in `block in call'

activesupport (7.2.2.1) lib/active_support/callbacks.rb:101:in `run_callbacks'

actionpack (7.2.2.1) lib/action_dispatch/middleware/callbacks.rb:30:in `call'

actionpack (7.2.2.1) lib/action_dispatch/middleware/debug_exceptions.rb:31:in `call'

actionpack (7.2.2.1) lib/action_dispatch/middleware/show_exceptions.rb:32:in `call'

logster (2.20.0) lib/logster/middleware/reporter.rb:40:in `call'

railties (7.2.2.1) lib/rails/rack/logger.rb:41:in `call_app'

railties (7.2.2.1) lib/rails/rack/logger.rb:29:in `call'

config/initializers/100-quiet_logger.rb:20:in `call'

config/initializers/100-silence_logger.rb:29:in `call'

actionpack (7.2.2.1) lib/action_dispatch/middleware/request_id.rb:33:in `call'

lib/middleware/enforce_hostname.rb:24:in `call'

rack (2.2.10) lib/rack/method_override.rb:24:in `call'

actionpack (7.2.2.1) lib/action_dispatch/middleware/executor.rb:16:in `call'

rack (2.2.10) lib/rack/sendfile.rb:110:in `call'

lib/middleware/processing_request.rb:12:in `call'

message_bus (4.3.8) lib/message_bus/rack/middleware.rb:60:in `call'

lib/middleware/request_tracker.rb:385:in `call'

actionpack (7.2.2.1) lib/action_dispatch/middleware/remote_ip.rb:96:in `call'

railties (7.2.2.1) lib/rails/engine.rb:535:in `call'

railties (7.2.2.1) lib/rails/railtie.rb:226:in `public_send'

railties (7.2.2.1) lib/rails/railtie.rb:226:in `method_missing'

rack (2.2.10) lib/rack/urlmap.rb:74:in `block in call'

rack (2.2.10) lib/rack/urlmap.rb:58:in `each'

rack (2.2.10) lib/rack/urlmap.rb:58:in `call'

unicorn (6.1.0) lib/unicorn/http_server.rb:634:in `process_client'

unicorn (6.1.0) lib/unicorn/http_server.rb:739:in `worker_loop'

unicorn (6.1.0) lib/unicorn/http_server.rb:547:in `spawn_missing_workers'

unicorn (6.1.0) lib/unicorn/http_server.rb:143:in `start'

unicorn (6.1.0) bin/unicorn:128:in `<top (required)>'

vendor/bundle/ruby/3.3.0/bin/unicorn:25:in `load'

vendor/bundle/ruby/3.3.0/bin/unicorn:25:in `<main>'
```

---

<div class="post-metadata">

### Author: ![Canapin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/canapin/32/119591_2.png) [@Canapin](https://meta.discourse.org/u/Canapin)
#### Post date: [February 4, 2025, 12:37pm UTC](https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416/2 "2025-02-04T12:37:59Z")

</div>

> [@Richie](#):
>
> _(The plus sign may be the significant key here, or it may be a red herring)_

> [@Enabling e-mail normalization by default](https://meta.discourse.org/t/enabling-e-mail-normalization-by-default/338641):
>
> Background In the past, Discourse has shipped with e-mail normalization off. As a result of this, users can create multiple accounts using the same canonical e-mail, through the use of [plus addressing](https://www.codetwo.com/admins-blog/plus-addressing/). For example, a user with an account tied to bob@discourse.org is able to create another account tied to bob+again@discourse.org. Discourse comes with the normalize\_emails site setting which can be flipped to either allow or disallow this. When turned on, it considers both e-mails above to be the …

Did you check the `normalize_emails` settings? Not saying there’s not a bug here 🙂

---

<div class="post-metadata">

### Author: ![Richie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/richie/32/115110_2.png) [@Richie](https://meta.discourse.org/u/Richie)
#### Post date: [February 4, 2025, 12:52pm UTC](https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416/3 "2025-02-04T12:52:16Z")

</div>

No, I hadn’t checked that setting, I did not know it existed, thanks @Canapin🙂

If this is the cause of the issue then the `Internal Server Error` bug needs catching and handling to tell the user why they can’t use this email address.

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [March 27, 2025, 3:10am UTC](https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416/4 "2025-03-27T03:10:25Z")

</div>

somebody is going to have a look at this over the next 4 weeks, we should be displaying a clear warning to the user not a “internal server error”

---

<div class="post-metadata">

### Author: ![Richie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/richie/32/115110_2.png) [@Richie](https://meta.discourse.org/u/Richie)
#### Post date: [April 30, 2025, 7:16pm UTC](https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416/8 "2025-04-30T19:16:36Z")

</div>

Thanks @sam

---

<div class="post-metadata">

### Author: ![davidb](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/davidb/32/554671_2.png) [@davidb](https://meta.discourse.org/u/davidb)
#### Post date: [May 9, 2025, 9:27am UTC](https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416/9 "2025-05-09T09:27:33Z")

</div>

This has been fixed with this commit:

[https://github.com/discourse/discourse/commit/b28df068fc9757a63c8792748228ff167973dae4](https://github.com/discourse/discourse/commit/b28df068fc9757a63c8792748228ff167973dae4)

If you have an unconfirmed email change, I would recommend deleting it first within the user preferences page (ie. `/my/preferences/account`) by clicking the wrench icon next to the unconfirmed email and clicking **Remove email**.

Afterwards you can begin the process of changing the email again, which should hopefully work correctly this time around.

---

<div class="post-metadata">

### Author: ![davidb](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/davidb/32/554671_2.png) [@davidb](https://meta.discourse.org/u/davidb)
#### Post date: [May 15, 2025, 6:28am UTC](https://meta.discourse.org/t/users-getting-internal-server-error-when-trying-to-change-email-address/350416/10 "2025-05-15T06:28:28Z")

</div>

This topic was automatically closed after 3 days. New replies are no longer allowed.
